PTA-stack(1051)

1051 Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

思路

这道题是考察stack的基础题,我们在学习数据结构时经常做这种选择题,给一个出栈序列判断其是否合法,这道题就是模拟这个过程。
通过挨个入栈操作,不断检查栈顶与出栈序列的元素是否相同,如果相同则出栈并向后移动出栈序列元素,在过程中需要判断栈是否为空!
模拟后如果栈为空则说明序列合法,否则序列不合法。
在每次操作后都要清空栈,以免影响下一次操作。

#include<bits/stdc++.h>
using namespace std;
stack<int> st;
vector<int> ans(1001);
int main() {
	int n,m,k;
	cin>>n>>m>>k;
	while(k--) {
		bool pan=false;
		while(!st.empty()) {
			st.pop();
		}
		for(int i=0; i<m; i++) {
			cin>>ans[i];
		}
		int cur=0;
		for(int j=0; j<m; j++) {
			st.push(j+1);
			if(st.size()>n) {
				pan=false;
				break;
			}
			while(st.size()&&ans[cur]==st.top()){
				cur++;
				st.pop();
			}
		}
		if(!st.empty()) pan=false;
		else pan=true;
		if(pan) cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

新西兰做的饭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值