PTA 02-线性结构4 Pop Sequence(25 分)

题目:
Given a stack which can keep numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M(the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of Nnumbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

胡乱分析:

补档.。。。。题目简单翻译下,给你一个容量为Capacity的堆栈,按照顺序push进Num个数,问是否可以pop出的指定数组,思路全在备注里了2333

代码:

#include <iostream>
#include <stack>
using namespace std;
int main() {
	int Capacity, Num, cnt;//Capacity堆栈容量  Num待检查的元素的个数  cnt组数
	cin >> Capacity >> Num >> cnt;
	while (cnt--) {
		int *a = new int[Num + 1];			//存放带检查元素的数组(下标从1开始)
		bool flag = true;					//一个检查堆栈是否溢出的标记
		stack<int> S;						//一个模拟用的堆栈
		for (int i = 1; i <= Num; i++) {
			cin >> a[i];
		}
		int p = 1;							//一个滑动的指针
		for (int i = 1; i <= Num; i++) {	//元素按照顺序入栈
			S.push(i);
			if (S.size() > Capacity) {		//如果超出堆栈容量
				flag = false; break;		//改变flag跳出循环
			}
			while (!S.empty() && S.top() == a[p]) {//顶端元素为a[p]
				S.pop();					//弹出这个元素
				p++;						//p指向数组下一个元素
			}
		}
		if (p - 1 == Num && flag) {			//如果整个数组均被检查完&&没有溢出堆栈容量
			cout << "YES" << endl;
		}
		else {
			cout << "NO" << endl;
		}
	}
}

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值