hdu 4786 Fibonacci Tree

Fibonacci Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4939    Accepted Submission(s): 1540


Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )  

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).  

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.  

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 
Sample Output
  
  
Case #1: Yes Case #2: No  

Source
 
Recommend
We have carefully selected several similar problems for you:   6022  6021  6020  6019  6018 
 
题意:Spanning Tree :生成树;要找是否有组成生成树的白边的个数是否是斐波那契数?
思路:找到这个图的最大生成树的白边树也就是权值和(maxx)和最小生成树的权值和(minn),找maxx-minn之间是否有斐波那契数!用最小生成树的kruskal算法,先按黑边取,得到一棵生成树,树的权值和就是白边的最小个数(minn);再先按白边取,得到一棵生成树,树的权值和就是白边的最大个数(maxx); 先得到的一棵最小生成树已经是一棵生成树了,我们再往里面合并任意边都不改变这个树是生成树的事实,但是最多可以合并maxx个白边(根据最大生成树)
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100005;

int N,M;
struct edge
{
    int u,v,w;
}e[maxn];
int par[maxn];
int a[30];

bool cmp(edge x,edge y)
{
    return x.w<y.w;
}

int Find(int x)
{
    if(par[x]==-1)
        return x;
    else
        return par[x]=Find(par[x]);
}

int min_krus(int n)
{
    memset(par,-1,sizeof(par));
    sort(e,e+M,cmp);
    int ans=0,cnt=0;

    for(int i=0;i<M;i++)
    {
        if(Find(e[i].u)!=Find(e[i].v))
        {
            par[Find(e[i].u)]=Find(e[i].v);
            ans+=e[i].w;
            cnt++;
        }
        if(cnt==n-1)
            break;
    }
    if(cnt<n-1) return -1;//不连通;
    else return ans;
}

int max_krus(int n)
{
    memset(par,-1,sizeof(par));
    sort(e,e+M,cmp);
    int ans=0,cnt=0;

    for(int i=M-1;i>=0;i--)
    {
        if(Find(e[i].u)!=Find(e[i].v))
        {
            par[Find(e[i].u)]=Find(e[i].v);
            ans+=e[i].w;
            cnt++;
        }
        if(cnt==n-1)
            break;
    }
    if(cnt<n-1)  return -1;
    else return ans;
}

int main()
{
    a[1]=1,a[2]=2;
    for(int i=3;i<30;i++)
    a[i]=a[i-1]+a[i-2];

    int T,t=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&N,&M);
        for(int i=0;i<M;i++)
            scanf("%d%d%d",&e[i].u,&e[i].v,&e[i].w);

        int maxx=max_krus(N);
        int minn=min_krus(N);
//        printf("%d %d\n",maxx,minn);

        printf("Case #%d: ",++t);
        if(maxx==-1||minn==-1)
        {
            printf("No\n");
            continue;
        }

        int flag=0;
        for(int i=1;i<30;i++)
        {
            if(a[i]>=minn&&a[i]<=maxx)
                flag=1;
        }
        if(flag) printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值