hdu5775 sum

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2560    Accepted Submission(s): 982


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 , 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

题意:输入n,m;下一行输入n个数字,问这n个数的序列中是否存在连续子序列整除m;

思路:逆向思考,连续子序列整除m也就是:

            (sum[j]-sum[i])%m==0 =》sum[j]%m-sum[i]%m==0 =》sum[i]%m==sum[j]%m;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;

const int maxn=100005;
int a[maxn],ans[maxn];
ll sum[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        memset(a,0,sizeof(a));
        memset(sum,0,sizeof(sum));
        memset(ans,0,sizeof(ans));

        int flag=0;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]%m==0)
                flag=1;
        }
        for(int i=1;i<=n;i++)
        {
            sum[i]=sum[i-1]+a[i];
            if(sum[i]%m==0)
                flag=1;
        }

        for(int i=1;i<=n;i++)
            ans[sum[i]%m]++;

        for(int i=1;i<m;i++)
            if(ans[i]>1)
                flag=1;

        if(flag)  printf("YES\n");
        else  printf("NO\n");
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值