Jolly Jumpers_UVA10038

题目

 A sequence of n > 0 integers is called a jolly jumper if the absolute values of the difference between successive elements take on all the values 1 through n − 1. For instance, 1 4 2 3 is a jolly jumper, because the absolutes differences are 3, 2, and 1 respectively. The definition implies that any sequence of a single integer is a jolly jumper. You are to write a program to determine whether or not each of a number of sequences is a jolly jumper. Input Each line of input contains an integer n ≤ 3000 followed by n integers representing the sequence. Output For each line of input, generate a line of output saying ‘Jolly’ or ‘Not jolly’. Sample Input 4 1 4 2 3 5 1 4 2 -1 6 Sample Output Jolly Not jolly

题目大意

eof输入

首先输入n,表示有n个数字。

然后判断每两个相邻数字的绝对值是否在(0,n)范围内,并且要求这些绝对值覆盖整个(0,n)区间

 算法: 贪心

 代码

#include <iostream>
#include <algorithm>
using namespace std;
int a[3005],b[3005]; 
int main()
{
	int n,i;
	while(cin>>n)
	{
		for(i=0;i<n;i++)
		{
			cin>>a[i];                        //数据输入到a中
		}	
		for(i=0;i<n-1;i++)                 //b用来存储相邻元素的绝对值
		{
			b[i+1]=abs(a[i]-a[i+1]);
		}
		sort(b+1,b+n);  //将绝对值数字排序
		for(i=1;i<=n-1;i++)
		{
			if(b[i]!=i)	break;            //看绝对值是否覆盖整个(0,n)区间 
		}                      
		if(i==n)                          //如果上一个绝对值判断循环正常结束
                                          //说明判断完了最后一个 那么全覆盖了
		cout<<"Jolly"<<endl;
		else
		cout<<"Not jolly"<<endl;            // <n说明中间break退出了 那么没有全部覆盖 
	}    
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Cherish_lii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值