Poj1753 Flip Game(状态压缩+BFS)

Flip Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 51439 Accepted: 21712

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000

又是一道状态压缩,4*4刚好16位。每个点的位数是:行数*4+列数而翻转即对这一位进行“异或”操作state^(1<<i)(state是当前的状态,i是棋子的序号),最终的状态要等于0或者65535

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>

using namespace std;
struct node{
	int state;
	int step;
	node(int state=0,int step=0):state(state),step(step){} 
};
int flag[70000];
void reversal(int &ste,int lot)
{
	int r=lot/4,c=lot%4;
	ste^=(0x1<<lot);
	if(r>=1)
	ste^=(0x1<<(lot-4));
	if(r<=2)
	ste^=(0x1<<(lot+4));
	if(c>=1)
	ste^=(0x1<<(lot-1));
	if(c<=2)
	ste^=(0x1<<(lot+1));
}
queue<node> q;
int bfs(int s)
{
	node a(s,0);
	flag[s]=1;
	q.push(a);
	while(!q.empty())
	{
		node fir=q.front();
		q.pop();
		if(fir.state==0||fir.state==65535) return fir.step;
		for(int i=0;i<16;i++)
		{
			node nxt=fir;
			reversal(nxt.state,i);
			if(!flag[nxt.state])
			{
				nxt.step++;
				q.push(nxt);
				flag[nxt.state]=1;
			}
		}
	}
	return -1;
}
char m[4][4];
int main()
{
	
	int beg=0;
	for(int i=0;i<4;i++)
	{
		scanf("%s",m[i]);
		for(int j=0;j<4;j++)
		{
			if(m[i][j]=='b')
			{
				beg^=(1<<(i*4+j));
			}
		}
	}
	int ans=bfs(beg);
	if(ans==-1) printf("Impossible\n");
	else printf("%d\n",ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值