KiKi's K-Number HDU - 2852 (树状数组求第K大,O(N)算法)

KiKi's K-Number

 HDU - 2852 

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations. 

Push: Push a given element e to container 

Pop: Pop element of a given e from container 

Query: Given two elements a and k, query the kth larger number which greater than a in container; 

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem? 

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values: 
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container. 

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container   

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number. 

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

题意:

要求我们设计一个数据结构,他有着插入,删除,查找大于A的第K大的数三种功能;

思路:

插入和删除都没什么好书的,至于大于A的第k大不妨转换一下求第sum(A)+K大(sum(A)为比A小的值的数量),然后直接套第K大的模板就可以了

AC代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<stack>
#include<cmath>
#include<queue>
#include<set>
#include<map>
#include<unordered_map>
#define endl '\n'
#define sc(x) scanf("%d",&x)
#define lowbit(x) x&(-x)
using namespace std;
const int size=1e5+5;
const int maxn=1e5+5;
int c[size];
void add(int x,int val)
{
	while(x<size)
	{
		c[x]+=val;
		x+=lowbit(x);
	}
}
int sum(int x)
{
	int ans=0;
	while(x)
	{
		ans+=c[x];
		x-=lowbit(x);
	}
	return ans;
}
int query(int k)
{
	int ans=0,cnt=0;
	for(int i=20;i>=0;i--)
	{
		
		ans+=(1<<i);
		//cout<<ans<<endl;if(ans<maxn)cout<<c[ans]<<endl;
		if(ans>=maxn||cnt+c[ans]>=k)
		{
			ans-=(1<<i);
		}
		else
		{
			cnt+=c[ans];
		}
		
	}
	return ans+1;
}
int main()
{
	int m;
	while(~scanf("%d",&m))
	{
		memset(c,0,sizeof(c));
		while(m--)
		{
			int op;
			int val;
			scanf("%d",&op);
			if(op==0)
			{
				
				sc(val);
				add(val,1);
			} 
			else if(op==1)
			{
				sc(val);
				if(sum(val)!=sum(val-1))
				add(val,-1);
				else cout<<"No Elment!"<<endl;
			}
			else
			{
				int k,a;
				sc(a),sc(k);
				int ans=query(sum(a)+k);
				if(ans==maxn) cout<<"Not Find!"<<endl;
				else cout<<ans<<endl;
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值