2377 Bad Cowtractors 最大树问题如何解决

网上几乎所有的答案都是在搜索的时候,把已经确定的点当做起始点,而并没有考虑已经确定的点当终点的情况,导致出现错误,详情可以见下面的红体代码,希望可以给大家带来帮助

Bad Cowtractors

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10944 Accepted: 4617
Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

// Bad Cowtractors.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include "iostream"
#include"math.h"  
using namespace std;
int n, m;
int map[100][100];
int vis[100];
int a, b, c;
int result(){
	int res=0;
	int max = 0;
	int p = 1;
	int temp=1;
	memset(vis, 0, sizeof(vis));
	for(int j = 2; j <= n; j++ ){
		if (vis[j] != 1 && map[p][j] > max){
			max = map[p][j];
			temp = j;
		}
	}
	p = temp;
	vis[1] = 1;
	res += max;
	max = 0;
	for (int i = 2; i <= n; i++){
		for(int j = 1; j <=n; j++){
<span style="color:#ff0000;"><strong>			if (vis[j] != 1 && map[p][j] > max ){
				max = map[p][j];
				temp = j;
			    }
			if (vis[j] != 1 && map[j][p] > max){
				max = map[j][p];
				temp = j;
			}</strong></span>
			
		}
		vis[p] = 1;
		p = temp;
		
		res += max;
		max = 0;

	}
	return res;

}

int _tmain(int argc, _TCHAR* argv[])
{ 
	
	memset(map,0,sizeof(map));
	cin >> n >> m;//输入点、边
	for (int i = 0; i < m; i++){//输入具体数据
		cin >> a >> b >> c;
		map[a][b] = c;
	}
	cout << result() << endl;

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值