HDU ACM1034——Candy Sharing Game

41 篇文章 0 订阅
3 篇文章 0 订阅

Candy Sharing Game

Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

题目大意:有一群小朋友围成一圈坐,他们都被发了偶数颗糖,如果他们的糖数不相同,则每个人将其糖数的一半给其右边的人(这一步每个人都是是同时进行的),如果给完后有人剩下奇数颗糖,老师就补给他一颗,循环往复直到所有人糖数相同,并输出换了多少轮糖和现在每个人的糖数。

#include<stdio.h>
int n,i,num[300],con;
int if_same(int num[]){	/*判断所有小朋友的糖果数是否相同*/
	for(i=1;i<n;i++)
		if(num[i]!=num[0])return 0;
	return 1;
}
int main()
{
	while(scanf("%d",&n)!=EOF){
		if(n==0)break;
		con=0;
		for(i=0;i<n;i++)
			scanf("%d",&num[i]);
		while(if_same(num)==0){ 
			for(i=0;i<n;i++)	/*每个人先失去一半糖*/ 
				num[i]=num[i]/2;
			int a=num[n-1];
			for(i=n-2;i>=0;i--){	/*从最后一个人开始,依次拿前一个人的那一半糖*/ 
				num[i+1]+=num[i];	/*注意必须从后往前拿*/ 
				if(num[i+1]%2==1)num[i+1]++;	/*如果拿到糖后是奇数,则加一*/ 
			}
			num[0]+=a;	/*第一个人拿最后一人的糖*/ 
			if(num[0]%2==1)num[0]++;
			con++;	/*记录轮次*/ 
		}
		printf("%d %d\n",con,num[0]); 
	}
	return 0;
 } 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值