Codeforces Round 927 (Div. 3) D. Card Game 题解 贪心

Card Game

题目描述

Two players are playing an online card game. The game is played using a 32-card deck. Each card has a suit and a rank. There are four suits: clubs, diamonds, hearts, and spades. We will encode them with characters ‘C’, ‘D’, ‘H’, and ‘S’, respectively. And there are 8 ranks, in increasing order: ‘2’, ‘3’, ‘4’, ‘5’, ‘6’, ‘7’, ‘8’, ‘9’.

Each card is denoted by two letters: its rank and its suit. For example, the 8 of Hearts is denoted as 8H.

At the beginning of the game, one suit is chosen as the trump suit.

In each round, players make moves like this: the first player places one of his cards on the table, and the second player must beat this card with one of their cards. After that, both cards are moved to the discard pile.

A card can beat another card if both cards have the same suit and the first card has a higher rank than the second. For example, 8S can beat 4S. Additionally, a trump card can beat any non-trump card, regardless of the rank of the cards, for example, if the trump suit is clubs (‘C’), then 3C can beat 9D. Note that trump cards can be beaten only by the trump cards of higher rank.

There were n n n rounds played in the game, so the discard pile now contains 2 n 2n 2n cards. You want to reconstruct the rounds played in the game, but the cards in the discard pile are shuffled. Find any possible sequence of n n n rounds that might have been played in the game.

输入描述

The first line contains integer t t t ( 1 ≤ t ≤ 100 1 \le t \le 100 1t100) — the number of test cases. Then t t t test cases follow.

The first line of a test case contains the integer number n n n ( 1 ≤ n ≤ 16 1\le n\le 16 1n16).

The second line of a test case contains one character, the trump suit. It is one of “CDHS”.

The third line of a test case contains the description of 2 n 2n 2n cards. Each card is described by a two-character string, the first character is the rank of the card, which is one of “23456789”, and the second one is the suit of the card, which is one of “CDHS”. All cards are different.

输出描述

For each test case print the answer to it:

  • Print n n n lines. In each line, print the description of two cards, in the same format as in the input: the first card that was played by the first player, and then the card that was used by the second player to beat it.
  • If there is no solution, print a single line “IMPOSSIBLE”.

If there are multiple solutions, print any of them.

样例输入 #1

8
3
S
3C 9S 4C 6D 3S 7S
2
C
3S 5D 9S 6H
1
H
6C 5D
1
S
7S 3S
1
H
9S 9H
1
S
9S 9H
1
C
9D 8H
2
C
9C 9S 6H 8C

样例输出 #1

3C 4C
6D 9S
3S 7S
IMPOSSIBLE
IMPOSSIBLE
3S 7S
9S 9H
9H 9S
IMPOSSIBLE
6H 9C
9S 8C

原题

CF——传送门
洛谷——传送门

代码

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);

    int t;
    cin >> t;
    while (t--)
    {
        int n;
        char c;
        cin >> n >> c;
        vector<pair<string, string>> ans;
        vector<string> v(2 * n);
        for (int i = 0; i < 2 * n; i++)
            cin >> v[i];
        auto cmp = [&](string a, string b) -> bool
        {
            // 同为王牌花色时,点数小在前
            if (a[1] == c && b[1] == c) // 事实上该判断可与第四条判断合并,但这样更加清晰
                return a[0] < b[0];
            // 判断2和判断3是使王牌花色在排序后位于其他花色的后面
            if (a[1] == c)
                return 0;
            if (b[1] == c)
                return 1;
            // 相同花色,点数小在前
            if (a[1] == b[1])
                return a[0] < b[0];
            // 不同花色,按字典序(只要给定任意一种规则排序即可,这边为了方便采用字典序)
            if (a[1] != b[1])
                return a[1] < b[1];
            return 1;
        };
        sort(v.begin(), v.end(), cmp); // 按贪心顺序排序,即先消去王牌花色外的可消去牌对,再用王牌花色消去剩下的牌
        int small = 0;                 // 被击败的牌即小牌的索引
        int big = 1;                   // 击败小牌的大牌的索引
        vector<bool> del(2 * n, 0);
        // 操作一:先消去王牌花色外的可消去牌对
        while (big <= 2 * n - 1)
        {
            if (v[big][1] == c) // 遇到王牌花色则退出循环
                break;
            // 可消去
            if (v[small][1] == v[big][1])
            {
                del[small] = 1;
                del[big] = 1;
                ans.push_back({v[small], v[big]});
                small += 2;
                big += 2;
            }
            // 不可消去
            else
            {
                small++;
                big++;
            }
        }
        vector<string> v2; // 保存完成操作一后仍剩下的牌,供操作二消去
        for (int i = 0; i < 2 * n; i++)
        {
            if (del[i] == 0)
                v2.push_back(v[i]);
        }
        // 操作二:再用王牌花色消去剩下的牌
        for (int i = 0; i < v2.size() / 2; i++)
        {
            int j = v2.size() - 1 - i;
            if (v2[j][1] == c)
                ans.push_back({v2[i], v2[j]});
            else
                break;
        }
        if (ans.size() == n)
        {
            for (int i = 0; i < ans.size(); i++)
            {
                cout << ans[i].first << ' ' << ans[i].second << '\n';
            }
        }
        else
            cout << "IMPOSSIBLE\n";
    }

    return 0;
}
  • 23
    点赞
  • 26
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Codeforces Round 894 (Div. 3) 是一个Codeforces举办的比赛,是第894轮的Div. 3级别比赛。它包含了一系列题目,其中包括题目E. Kolya and Movie Theatre。 根据题目描述,E. Kolya and Movie Theatre问题要求我们给定两个字符串,通过三种操作来让字符串a等于字符串b。这三种操作分别为:交换a中相同位置的字符、交换a中对称位置的字符、交换b中对称位置的字符。我们需要先进行一次预处理,替换a中的字符,然后进行上述三种操作,最终得到a等于b的结果。我们需要计算预处理操作的次数。 根据引用的讨论,当且仅当b[i]==b[n-i-1]时,如果a[i]!=a[n-i-1],需要进行一次操作;否则不需要操作。所以我们可以遍历字符串b的前半部分,判断对应位置的字符是否与后半部分对称,并统计需要进行操作的次数。 以上就是Codeforces Round 894 (Div. 3)的简要说明和题目E. Kolya and Movie Theatre的要求。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [Codeforces Round #498 (Div. 3) (A+B+C+D+E+F)](https://blog.csdn.net/qq_46030630/article/details/108804114)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [Codeforces Round 894 (Div. 3)A~E题解](https://blog.csdn.net/gyeolhada/article/details/132491891)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值