HDU 5120 两圆环覆盖的面积(几何)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1340    Accepted Submission(s): 516


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5498  5497  5496  5495  5494
此题题意是让求两个圆心坐标不同但内径和外径相同的的两个圆环,相交覆盖的面积
 
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define eps 1e-9
#define PI acos(-1)
using namespace std;
struct Point
{
	double x,y;
	Point(){};
	Point(double a,double b)
	{
		x=a,y=b;
	}
	Point operator - (const Point a)const
	{
		return Point(x-a.x,y-a.y);
	}
	double operator *(const Point a)const
	{
		return x*a.x+y*a.y;
	}
};
double dist(Point a,Point b)
{
	return sqrt((a-b)*(a-b));
}
double Area(Point a,double r1,Point b,double r2)
{
	double k=dist(a,b);
	if(k+eps>=r1+r2) //相切或相离
		return 0;
	if(k<=fabs(r1-r2)+eps)  //大圆包含小圆 ,eps应该放在<后
	{
		double Min=min(r1,r2);
		return PI*Min*Min;
	}
	double x=(k*k+r1*r1-r2*r2)/(2.0*k);
	double j1=acos(x/r1);  //直角三角形
	double j2=acos((k-x)/r2);
	return (j1*r1*r1+j2*r2*r2-k*r1*sin(j1));
}
int main()
{
	int T;
	while(~scanf("%d",&T))
	{
		int Case=0;
		while(T--)
		{
			double r,R;
			Point C1,C2;
			Case++;
			scanf("%lf%lf",&r,&R);
			scanf("%lf%lf%lf%lf",&C1.x,&C1.y,&C2.x,&C2.y);
double area=Area(C1,R,C2,R)+Area(C1,r,C2,r)-2*Area(C1,r,C2,R);
           printf("Case #%d: ",Case);
			printf("%.6lf\n",area);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值