HDU5120 Intersection(求两圆环相交)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)Total Submission(s): 3178    Accepted Submission(s): 1203

Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.
A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.
Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
   
   
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
    
    
Case #1: 15.707963 Case #2: 2.250778
 
题意:给你圆环的内半径和外半径,再给你两个圆环(圆环相同)的中点坐标,求两个圆环重合的面积
思路:先画个图,由图可知黑色部分为相交的面积,将一个圆环分解成一个小圆和一个大圆,用area表示两个圆相交的面积,那么黑色部分面积就是area(A,B)-area(A,b)-area(B,a)+area(a,b)

只用写一个两个圆相交面积的函数即可

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define PI 3.14159265357
struct circle
{
    double x,y;
    double r;
};
double dis(circle a,circle b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double solve(circle a, circle b) {
    double d = dis(a, b);
    if (d >= a.r + b.r)
        return 0;
    if (d <= fabs(a.r - b.r)) {
        double r = a.r < b.r ? a.r : b.r;
        return PI * r * r;
    }
    double ang1 = acos((a.r * a.r + d * d - b.r * b.r) / 2. / a.r / d);
    double ang2 = acos((b.r * b.r + d * d - a.r * a.r) / 2. / b.r / d);
    double ret = ang1 * a.r * a.r + ang2 * b.r * b.r - d * a.r * sin(ang1);
    return ret;
}
int main()
{
    circle a,b,A,B;
    double r,R;
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf",&r,&R);
        a.r=b.r=r;
        A.r=B.r=R;
        scanf("%lf%lf%lf%lf",&a.x,&a.y,&b.x,&b.y);
        A.x=a.x;
        A.y=a.y;
        B.x=b.x;
        B.y=b.y;
        printf("Case #%d: ",cas++);
        double area=solve(A,B)-solve(A,b)-solve(B,a)+solve(a,b);
        printf("%lf\n",area);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值