Score of a bamboo = Φ (bamboo's length)
(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.
The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.
InputInput starts with an integer T (≤ 100), denoting the number of test cases.
Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].
OutputFor each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.
Sample Input3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
Sample OutputCase 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<map>
using namespace std;
typedef long long LL;
#define MAXN 100006
#define MAXL 1299710
int prime[MAXL];
int check[MAXL];
void init()
{
int tot=0;
memset(check,0,sizeof(check));
for(int i=2; i<MAXL; i++)
{
if(!check[i])
{
prime[tot++]=i;
}
for(int j=0; j<tot; j++)
{
if(i*prime[j]>MAXL)
{
break;
}
check[i*prime[j]]=1;
if(i%prime[j]==0)
{
break;
}
}
}
}
int main()
{
init();
int n;
int zz;
LL sum;
int T;
while(scanf("%d",&T)!=EOF)
{
for(int j=1; j<=T; j++)
{
scanf("%d",&n);
sum=0;
for(int i=0; i<n; i++)
{
scanf("%d",&zz);
sum+=*upper_bound(prime,prime+100005,zz);
/*
* lower_bound(a,a+n,val): 返回容器中第一个值【大于或等于】val的元素的iterator位置
* upper_bound(a,a+n,val)返回容器中第一个值【大于】val的元素的iterator位置
* 在前面加*号可以返回对应的值
*/
}
printf("Case %d: %lld Xukha\n",j,sum);
}
}
return 0;
}