Bi-shoe and Phi-shoe

本文介绍了一项基于竹竿跳的传统运动背景下的数学问题,旨在寻找满足特定条件的最小质数,通过预处理质数表并使用二分查找算法来解决。问题设定在一个虚构的国度Xzhiland里,教练需要为学生购买竹竿,每根竹子的得分由其长度的欧拉函数决定。
摘要由CSDN通过智能技术生成

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

思路:每个数据为欧拉函数值,求大于每个数值的最小质数,打表二分

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<stack>
#include<queue>
#include<map>
using namespace std;
typedef long long LL;

#define MAXN 100006
#define MAXL 1299710


int prime[MAXL];
int check[MAXL];

void init()
{
    int tot=0;
    memset(check,0,sizeof(check));
    for(int i=2; i<MAXL; i++)
    {
        if(!check[i])
        {
            prime[tot++]=i;

        }
        for(int j=0; j<tot; j++)
        {
            if(i*prime[j]>MAXL)
            {
                break;
            }
            check[i*prime[j]]=1;
            if(i%prime[j]==0)
            {
                break;
            }
        }
    }

}
int main()
{
    init();
    int n;
    int zz;
    LL sum;
    int T;
    while(scanf("%d",&T)!=EOF)
    {
        for(int j=1; j<=T; j++)
        {
            scanf("%d",&n);
            sum=0;
            for(int i=0; i<n; i++)
            {
                scanf("%d",&zz);
                sum+=*upper_bound(prime,prime+100005,zz);
                /*
                *  lower_bound(a,a+n,val): 返回容器中第一个值【大于或等于】val的元素的iterator位置
                *  upper_bound(a,a+n,val)返回容器中第一个值【大于】val的元素的iterator位置
                *  在前面加*号可以返回对应的值
                */
            }
            printf("Case %d: %lld Xukha\n",j,sum);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值