LightOJ 1007 Mathematically Hard

                                Mathematically Hard  

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237

Note

Euler's totient function  applied to a positive integer n is defined to be the number of positive integers less than or equal to n that are relatively prime to n is read "phi of n."

Given the general prime factorization of , one can compute  using the formula

题意:对于x,score(x)=n^2,n为1~x之间与x互斥的数的个数。输入a和b两个数,求a~b之间所有数的score之和。
思路:利用欧拉函数求各个数互斥的个数,之后就可以求解了。数据大,用typedef unsigned long long,输出是用%llu。
代码参考:
               
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<queue>
#include<cstring>
#define max(a,b) a>b?a:b
#define inf 0x3f3f3f3f
#define pi 3.1415926535897932
using namespace std;

typedef unsigned long long ll;
const int N = 5000010;
ll arr[N];

void euler()//筛选法求欧拉函数 
{
    for(int i=1;i<N;i++) arr[i]=i;
    for(int i=2;i<N;i++)
        if(arr[i]==i)
            for(int j=i;j<N; j+=i)
                arr[j]=arr[j]/i*(i-1);
}

int main()
{
    int t,ans=0;
    scanf("%d",&t);
    euler();
    for(int i=1;i<N;i++)
        arr[i]=arr[i-1]+arr[i]*arr[i];
    while(t--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",++ans,arr[b]-arr[a-1]);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值