Mathematically Hard (欧拉定理)

Mathematically Hard
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input

Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b(2 ≤ a ≤ b ≤ 5 * 106).

Output

For each case, print the case number and the summation of all the scores from a to b.

Sample Input

3

6 6

8 8

2 20

Sample Output

Case 1: 4

Case 2: 16

Case 3: 1237





数论 中,对正 整数 n 欧拉函数 \varphi(n) 是小于或等于 n 的正整数中与 n 互质 的数的数目。


#include<stdio.h>
#include<string.h>
#define Max 5000005
unsigned long data[Max];
void Deal() //求1到MAX的所有数的欧拉函数 
{
	int i, j;
	memset(data, 0, sizeof(data));
	data[1] = 1;
	for(i = 2; i < Max; i++)
	{
		if(!data[i])
		{
			for(j = i; j < Max; j+= i)
			{
				if(!data[j])
					data[j] = j;
				data[j] = data[j]/i*(i-1);
			}
		}
	}
	for(i = 2; i <= Max; i++)//预处理前i项的和  
		data[i] = data[i-1] + data[i] * data[i];
}
int main()
{
	Deal();
	int t, i, n, test = 1, m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n, &m);
		printf("Case %d: %llu\n", test++, data[m]- data[n-1]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值