Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 29627 | Accepted: 9964 |
Description
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
Sample Input
5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100
Sample Output
90
Hint
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.
Source
现在写单源最短距离越来越喜欢用堆来优化了,跑的时间明显快了
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<stack>
#include<algorithm>
using namespace std;
const int N=1010;
struct edge{int to,cost;};
typedef pair<int,int> p;
vector<edge> g[N];
int dis[N];
const int inf=10000000;
void dijkstra(int s)
{
fill(dis,dis+N,inf);
dis[s]=0;
priority_queue<p> que;
que.push(make_pair(0,s));
while(!que.empty())
{
p p1=que.top();que.pop();
int x=p1.first;
int y=p1.second;
for(int i=0;i<g[y].size();i++)
{
edge e=g[y][i];
if(dis[e.to]>dis[y]+e.cost)
{
dis[e.to]=dis[y]+e.cost;
que.push(make_pair(dis[e.to],e.to));
}
}
}
}
void init()
{
for(int i=0;i<N;i++)
g[i].clear();
}
int main()
{
int T,N;
while(scanf("%d%d",&T,&N)!=EOF)
{
init();
for(int i=0;i<T;i++)
{
int aa,bb,cc;
scanf("%d%d%d",&aa,&bb,&cc);
edge tmp;
tmp.to=bb;
tmp.cost=cc;
g[aa].push_back(tmp);
tmp.to=aa;
g[bb].push_back(tmp);
}
dijkstra(N);
printf("%d\n",dis[1]);
}
return 0;
}