1915: H
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 285 Solved: 121
Submit Status Web Board
Description
在三维空间里,晴天得到了一些坐标,然后他想知道这些坐标有没有重合的哇,然后若两个坐标是重合的也就是x=x,y=y,z=z。然后他把这个任务交给你啦。
Input
输入第一行包含一个整数t表示有多少组数据。
每组数据一个整数n,表示有多少个点。
接下来n行,每行有三个整数x,y,z表示一个点的坐标.
0<=n<=200000,0<=x,y,z<100,t<=20
Output
若有两个点重合输出yes,否则输出no
Sample Input
1 3 1 1 1 1 2 1 1 1 1
Sample Output
yes
HINT
Source
#include<stdio.h>
#include<string.h>
int map[105][105][105];
int main() {
int T;
scanf("%d",&T);
while(T--) {
int n;
memset(map,0,sizeof(map));
scanf("%d",&n);
int flag=0;
for(int i=0; i<n; i++) {
int x,y,z;
scanf("%d%d%d",&x,&y,&z);
if(map[x][y][z]) {
flag=1;
}
map[x][y][z]=1;
}
if(!flag)
printf("no\n");
else
printf("yes\n");
}
return 0;
}
题目地址:http://acm.zzuli.edu.cn/zzuliacm/problem.php?id=1915