stack《==》 先序和中序

该篇博客探讨了一种非递归方法,通过栈来实现二叉树的中序遍历,并基于给定的先序和中序遍历序列推导出后序遍历。文章提供了具体的C++代码示例,解释了如何根据输入的push和pop操作序列来构造并输出对应的后序遍历序列。
摘要由CSDN通过智能技术生成

03-树3 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

这个题,利用stack 非递归实现了,先序和中序

push 操作得到的是先序遍历

pop 操作给定的是中序遍历(画个图就明白了。。。)

那么题目就变成了根据先序和中序输出后序

可以复习下 先序中序得到后序遍历

#include <iostream>
#include <stack>
using namespace std;
#define Max 100
//给定push 操作得到的是先序遍历
// pop 操作给定的是中序遍历
//那么题目就变成了根据先序和中序输出后序
int pre[Max];
int in[Max];
int post[Max];
void solve(int prel, int inl, int postl, int n) {
  if (n == 0) return;
  if (n == 1) {
    post[postl] = pre[prel];
    return;
  }
  int i;
  int root = pre[prel];
  post[postl + n - 1] = root;  //那么根节点就是后序遍历的最后一个
  for (i = 0; i < n; i++)
    if (in[inl + i] == root) break;
  int L = i;
  int R = n - L - 1;
  //分别递归左右子树
  solve(prel + 1, inl, postl, L);
  solve(prel + L + 1, inl + L + 1, postl + L, R);
}

int main() {
  int n;
  stack<int> sta;
  scanf("%d\n", &n);
  int j = 0, k = 0;
  for (int i = 0; i < 2 * n; i++) {
    string s;
    cin >> s;
    int x;
    if (s == "Push") {
      cin >> x;
      sta.push(x);
      pre[j++] = x;
    } else {
      in[k++] = sta.top();  
      sta.pop();
    }
  }
  solve(0, 0, 0, n);
  for (int m = 0; m < n; m++) {
    if (m != 0)
      printf(" %d", post[m]);
    else
      printf("%d", post[m]);
  }
  return 0;
}

 

 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值