POJ 3320 Jessica's Reading Problem(尺取法+STL)

Jessica's Reading Problem

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18206 Accepted: 6290

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

题意描述:为了准备考试,Jessica开始读一本很厚的课本。要想通过考试,必须要课本上每个知识点看一遍。这本书一共有P页,第i页恰好有一个知识点a[i],同一个知识点可能被多页反复提到。所以她想阅读连续的一些页把书本中所有的知识点全覆盖到。给定每页写到的知识点,求出阅读的最少页数。
分析:用stl里的set求出书中知识点的总个数,再用map对应每个知识点出现的次数,剩下的就跟尺取法的思路一样啦。

这里简单的总结下set用法:

set<k> set1; //创建一个名为set1的空set对象,其键类型为k。

set<k> set2(set1); //创建set1的副本set2,set2与set1必须有相同的键类型和值类型。

set<k> set3(b, e); //创建set类型的对象set3,存储迭代器b和e标记的范围内所有元素的副本。元素的类型必须能转换为k类型。

set的各常见函数列表如下:

c++ stl容器set成员函数:begin()--返回指向第一个元素的迭代器

c++ stl容器set成员函数:clear()--清除所有元素

c++ stl容器set成员函数:count()--返回某个值元素的个数

c++ stl容器set成员函数:empty()--如果集合为空,返回true

c++ stl容器set成员函数:end()--返回指向最后一个元素的迭代器

c++ stl容器set成员函数:find()--返回一个指向被查找到元素的迭代器

c++ stl容器set成员函数:insert()--在集合中插入元素

c++ stl容器set成员函数:max_size()--返回集合能容纳的元素的最大限值

c++ stl容器set成员函数:size()--集合中元素的数目

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
#define inf 0x3f3f3f3f
int a[1000010];//序列数组 

int main()
{
	int n,i;
	int start,end;//start为区间的左端点,end为区间的右端点
	int sum,s;
	int ans=inf;
	while(scanf("%d",&n) !=EOF)
	{
		set<int>book;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
			book.insert(a[i]);
		}
		s=book.size();//记录知识点的个数 
		start=end=1;//初始区间的化左、右端点 
		sum=0; 
		map<int,int>dis;//对应每个知识点出现的次数 
		while(1)//死循环 
		{	
			while(end<=n&&sum<s)//当区间的右端点在n内并且连续序列中知识点的个数小于s
			{
				if(dis[a[end]]==0)//知识点第一次出现 
					sum++;//覆盖知识点个数加一 
				dis[a[end]]++;//记录知识点所出现的个数 
					end++;//右端点右移一个单位 
			}
			if(sum<s)//如果区间右端点到达n时覆盖知识点个数还小于s时停止循环
				break;
			ans=min(ans,end-start);//找出最短的区间使其区间内的知识点个数等于s 
			dis[a[start]]--;
			if(dis[a[start]]==0)//有一个知识点出现的次数为0了,就是减少了一个知识点
				sum--;
			start++;//左端点向右推进一个单位 
		}
		printf("%d\n",ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值