poj 3259 Wormholes SPFA

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 28008 Accepted: 10080

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint
For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

====================================================================================

题目大意:FJ有若干农场,每个农场先描述若干条路径,两个点之间可以有多条路径,然后描述若干个虫洞,虫洞也连接两个点,虫洞都是单向的。走路径消耗时间,走虫洞可以回到过去。问在FJ在农场中可能在更早的时间回到曾经到过的点吗?


解题思路:可以看出就是求图中有没有负边权环,而且起点可能是农场中任一点。那么就可以枚举起点用SPFA了。实际上,枚举起点超时了,只试起点1却能ac,不禁感觉数据好坑。

//Memory: 1592K	Time: 485MS

#include<cstdio>
#include<deque>
using namespace std;

const int N = 510;
const int INF = 0x7fffffff;

int g[N][N], n, d[N];
int cnt[N];
bool in_q[N];
//SPFA算法
bool SPFA(int s)
{
    deque<int> q;                                     //建立双端队列
    for( int i = 1 ; i <= n ; i++ )
    {
        cnt[i] = 0;                                   //初始化扩展计数器
        d[i] = INF;                                   //初始化d值
        in_q[i] = false;                              //初始化in队列标记
    }
    q.push_back(s);                                   //起点入队列
    cnt[s]++;                                         //扩展计数器自加
    d[s] = 0;                                         //到起点距离置0
    in_q[s] = true;                                   //标记in队列
    while(!q.empty())
    {
        int v = q.front();
        q.pop_front();                                //队头出队列
        in_q[v] = false;                              //标记出队列
        for( int i = 1 ; i <= n ; i++ )
        {
            if( g[v][i] < INF && d[v]+g[v][i] < d[i] )
            {
                d[i] = d[v]+g[v][i];                  //松弛
                if( !in_q[i] )                        //如果不在队列中
                {
                    in_q[i] = true;                   //入队列
                    if( ++cnt[i] >= n )
                        return false;
                    if( !q.empty() && d[i] > d[q.front()] )
                        q.push_back(i);
                    else
                        q.push_front(i);
                }
            }
        }
    }
    return true;                                      //不连通也默认成功,因为目的只是找负边权环
}

int main()
{
    int fn, m, w;
    scanf("%d", &fn);
    while(fn--)
    {
        scanf("%d%d%d", &n, &m, &w);
        for( int i = 1 ; i <= n ; i++ )
            for( int j = i+1 ; j <= n ; j++ )
                g[i][j] = g[j][i] = INF;              //初始化邻接矩阵
        while(m--)
        {
            int s, e, t;
            scanf("%d%d%d", &s, &e, &t);
            if( t < g[s][e] )                         //处理重边
                g[s][e] = g[e][s] = t;
        }
        while(w--)
        {
            int s, e, t;
            scanf("%d%d%d", &s, &e, &t);
            g[s][e] = -t;
        }
        printf("%s\n", SPFA(1)?"NO":"YES");           //只试起点1
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值