HDU 1071 The area

P.S.谁能告诉我这行怎么去掉

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 11337    Accepted Submission(s): 8008
Problem Description
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?Note: The point P1 in the picture is the vertex of the parabola.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 
Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 
Sample Input
 
 
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
 
Sample Output
 
  
33.33
40.69
Hint
For float may be not accurate enough, please use double instead of float.

题目大意:输入三个点的坐标,这三点确定了一个抛物线,其中p1是抛物线的顶点,连接p2,p3,求闭合区域面积。

数学问题,通过三个点的坐标求得抛物线和直线的表达式,然后相减求积分即可求出面积。

/*
积分问题,求抛物线与直线之间区域的面积。
抛物线顶点公式  顶点为(h,k) y=a(x-h)^2+k(a≠0)
直线式                      y=cx+d
相减得                      f(x)=a(x-h)^2-cx+k-d
区域面积就是                s=F(x3)-F(x2);
*/
#include<stdio.h>
#include<math.h>
int main(){
    int t;
    double x1,x2,x3,y1,y2,y3;
    scanf("%d",&t);
    while(t--){
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        double s,a,h,k,c,d;
        h=x1;
        k=y1;
        c=(y3-y2)/(x3-x2);
        d=y3-c*x3;
        a=(y2-k)/( (x2-h)*(x2-h) );

        s=a*(x3-h)*(x3-h)*(x3-h)/3-c*x3*x3/2+(k-d)*x3;
        s-=a*(x2-h)*(x2-h)*(x2-h)/3-c*x2*x2/2+(k-d)*x2;
        if(s<0) s=-s;//然而后台数据并不用考虑这种情况,或许题干说了,不过没看到。
        printf("%.2lf\n",s);
    }
    return 0;
}








  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值