HDU 1071 The area(微积分 计算几何)

11 篇文章 0 订阅

原题

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)


Problem Description

Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.


Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).



Output

For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.



Sample Input

2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222



Sample Output

33.33 40.69

题意


二维平面有一条直线与一条开口向下的抛物线相交,现在给出抛物线顶点以及两个交点,求出直线与抛物线围成的面积。

涉及知识及算法


微积分
设抛物线方程为 y=y1-a*(x-x1)^2 ,带入点(x3,y3)得 a= ,由两交点得到直线 方程 ,所以直线与抛物线围成的面积 这里写图片描述  

代码


#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
    double x1,x2,x3,y1,y2,y3;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3);
        //pow(x,y) 计算x的y次方。x、y及函数返回值都是double型
        printf("%.2lf\n",(y1-y3)*(x3-x2)-(y1-y3)*(pow(x3-x1,3)-pow(x2-x1,3))/(3.0*pow(x3-x1,2))+(y3-y2)*(x3-x2)/2.0);
    }
    return 0;
}

文章转载自CSDN博主ZSQ,链接http://blog.csdn.net/v5zsq/article/details/48085929,表示感谢。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值