Tautology-状压

Tautology
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11716 Accepted: 4437

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not


题目链接:http://poj.org/problem?id=3295

题目大意:

此题是让你判断式子最后的答案是否永真,离散好的大神应该看图就能看懂题,根据上表,判断输入的字符串是否为永真式,poj水题,本想不懂脑子用多重for循环直接水过,但是恰巧金桔路过,深深地鄙视了我的for循环,我。。。。。。最终决定,上状压,当然,金桔就是金桔,代码力求简洁。

题解:

共五个变元,p,q,r,s,t,每一个变元有0和1两种状态,共有1<<5种状态,对应每一个变元的值,直接上状压!

本渣的代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <stack>
using namespace std;
bool f(int h1,int h2,char c)
{
    switch(c)
    {
    case 'K':
        return h1&&h2;
    case 'A':
        return h1||h2;
    case 'C':
        return (!h1&&h2)||h1==h2;
    case 'E':
        return h1==h2;
    default :
        break;
    }
    return 0;
}
bool judge(char s[])
{
    int len=strlen(s);
    bool v[10];
    stack<bool> Q;
    int i,j;
    for(i=0;i<1<<5;i++)
    {
        int t=i;
        for(j=0;j<5;j++)
        {
            v[j]=t%2;
            t>>=1;
        }
        while(!Q.empty())
            Q.pop();
        for(j=len-1;j>=0;j--)
        {
            if(s[j]>='p'&&s[j]<='t')
                Q.push(v[s[j]-'p']);
            else if(s[j]=='N')
            {
                int h=Q.top();
                Q.pop();
                h=!h;
                Q.push(h);
            }
            else
            {
                int h1=Q.top();
                Q.pop();
                int h2=Q.top();
                Q.pop();
                int h=f(h1,h2,s[j]);
                Q.push(h);
            }
        }
        if(!Q.top())
            return 0;
    }
    if(Q.top())
        return 1;
    return 0;
}
int main()
{
    char s[1000];
    while(~scanf("%s",s)&&*s!='0')
    {
        printf(judge(s)?"tautology\n":"not\n");
    }
    return 0;
}


好久没有写点东西了,颓废了好长时间了,也落后了别人好多了,现在只想认真努力,借用前两天看的电影中的一句话,我们学习不是为了分数和比赛的成绩,而是为了完善我们自己,加油吧!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值