(构造法)Tautology

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

  • p, q, r, s, and t are WFFs
  • if w is a WFF, Nw is a WFF
  • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
  • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
  • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1

A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example,ApNp is a tautology because it is true regardless of the value of p. On the other hand,ApNq is not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input

ApNp
ApNq
0

Sample Output

tautology
not

Source

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
using namespace std;
char wff[150];
int pp,qq,rr,ss,tt,len,flag;
stack<int>s;
int panduan(char a)
{
   switch(a)
   {
      case 'p':s.push(pp);return 1;
      case 'q':s.push(qq);return 1;
      case 'r':s.push(rr);return 1;
      case 's':s.push(ss);return 1;
      case 't':s.push(tt);return 1;
   }
   return 0;
}
void chuli(char a)
{  int x,y;
   switch(a)
    {
       case 'K':x=s.top();
                s.pop();
                y=s.top();
                s.pop();
                s.push(x&&y);
                break;
       case 'A':x=s.top();
                s.pop();
                y=s.top();
                s.pop();
                s.push(x||y);
                break;
       case 'N':x=s.top();
                s.pop();
                s.push(!x);
                break;
       case 'C':x=s.top();
                s.pop();
                y=s.top();
                s.pop();
                s.push((!x)||y);
                break;
        case 'E':x=s.top();
                 s.pop();
                 y=s.top();
                 s.pop();
                 s.push(x==y);
                 break;
    }
    return;
}
int main()
{
    int i;
    while(~scanf("%s",wff)&&(wff[0]!='0'))
    {
        flag=1;
        len=strlen(wff);
        for(pp=0;pp<=1;pp++)
        {
            for(qq=0;qq<=1;qq++)
            {
                for(rr=0;rr<=1;rr++)
                 {
                    for(ss=0;ss<=1;ss++)
                    {
                        for(tt=0;tt<=1;tt++)
                        {
                            for(i=len-1;i>=0;i--)
                            {
                                if(!panduan(wff[i]))
                                    chuli(wff[i]);
                            }
                            if(s.top()!=1)
                            {
                               flag=0;
                            }//栈到最后只剩一个元素,是真则满足条件
                            s.pop();//清空栈
                        }
                        if(!flag)
                        break;
                    }
                    if(!flag)
                        break;
                 }
                 if(!flag)
                    break;
            }
            if(!flag)
                break;
        }
        if(flag==1)
            printf("tautology\n");
        else printf("not\n");
    }
    return 0;
}

大致题意:

输入由pqrstKANCE10个字母组成的逻辑表达式,

其中pqrst的值为1true)或0false),即逻辑变量;

KANCE为逻辑运算符,

K --> and:  x && y

A --> or:  x || y

N --> not :  !x

C --> implies :  (!x)||y

E --> equals :  x==y

问这个逻辑表达式是否为永真式。

PS:输入格式保证是合法的

 

解题思路:

p, q, r, s, t不同的取值组合共32种情况,枚举不同取值组合代入逻辑表达式WFF进行计算。

如果对于所有的取值组合,WFF值都为 true,则结果为 tautology,否则为 not
  

WFF的计算方法:

从字符串WFF的末尾开始依次向前读取字符。

构造一个栈stack,当遇到逻辑变量 p, q, r, s ,t则将其当前的值压栈;

遇到 N 则取栈顶元素进行非运算,运算结果的值压栈;

遇到K, A, C, E则从栈顶中弹出两个元素进行相应的运算,将结果的值压栈。 

由于输入是合法的,当字符串WFF扫描结束时,栈stack中只剩一个值,该值就是逻辑表达式WFF的值。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值