Finding Nemo--BFS

Finding Nemo
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 9060 Accepted: 2122

Description

Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help. 
After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero. 
All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo. 
Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo. 

We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.

Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors. 
Then follow M lines, each containing four integers that describe a wall in the following format: 
x y d t 
(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall. 
The coordinates of two ends of any wall will be in the range of [1,199]. 
Then there are N lines that give the description of the doors: 
x y d 
x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted. 
The last line of each case contains two positive float numbers: 
f1 f2 
(f1, f2) gives the position of Nemo. And it will not lie within any wall or door. 
A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.

Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.

Sample Input

8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output

5
-1
题目链接:http://poj.org/problem?id=2049

   

这个蛋疼的题。。。

题意大概是说海底总动员的小鱼尼莫是一个熊孩子,独自进入深海区不慎进入了海底迷宫,不幸的是他忘记了回家的路,他给他爸爸马林发送求救信号,他爸看了看迷宫地图(不知哪来的),迷宫里有门和墙组成。马林不能穿墙,并且也要尽量少开门(可能因为开门的时候会遭到水母的毒)。请你计算出救出他儿子的最少开门次数。

卡了我将近一天!我的思路是对的,大体代码也是对的,我一开始是用三维数组存的图,前两维是坐标,第三位是平行于x轴还是y轴,然后卡了,小豪又说我存图有问题,x轴和y轴随便写,我就改了,写完后对了一下题解看了看我的存图,恩,没错,但是他怎么遍历的比我简单,恩,好吧,按照网上的改了改,又优化了一遍,我还是第一次用结构体的优先队列。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
    int x,y;
    int door;
    bool operator < (const node &a) const{
        return a.door<door;
    }//结构体优先队列的判断
}xin;
int n,m,sx,sy,maxx,maxy;
int dis[300][300],h[300][300],l[300][300];

void BFS(){
    priority_queue<node> q;
    while(!q.empty())
        q.pop();
    for(int i=0;i<=maxx;i++)
        for(int j=0;j<=maxy;j++)
            dis[i][j]=inf;
    xin.x=0,    xin.y=0,    xin.door=0;
    dis[0][0]=0;
    q.push(xin);
    while(!q.empty()){
        xin=q.top();
        q.pop();
        int x=xin.x,    y=xin.y;
        if(x==sx && y==sy)
            return ;
        if(y+1<=maxy && dis[x][y+1]>dis[x][y]+h[x][y+1]){
            dis[x][y+1]=dis[x][y]+h[x][y+1];
            xin.x=x;
            xin.y=y+1;
            xin.door=dis[x][y+1];
            q.push(xin);
        }
        if(y-1>=0 && dis[x][y-1]>dis[x][y]+h[x][y]){
            dis[x][y-1]=dis[x][y]+h[x][y];
            xin.x=x;
            xin.y=y-1;
            xin.door=dis[x][y-1];
            q.push(xin);
        }
        if(x-1>=0 && dis[x-1][y]>dis[x][y]+l[x][y]){
            dis[x-1][y]=dis[x][y]+l[x][y];
            xin.x=x-1;
            xin.y=y;
            xin.door=dis[x-1][y];
            q.push(xin);
        }
        if(x+1<=maxx && dis[x+1][y]>dis[x][y]+l[x+1][y]){
            dis[x+1][y]=dis[x][y]+l[x+1][y];
            xin.x=x+1;
            xin.y=y;
            xin.door=dis[x+1][y];
            q.push(xin);
        }
    }
    dis[sx][sy]=-1;
}
int main(){
    int x,y,d,t;
    double f1,f2;
    while(~scanf("%d%d",&n,&m)){
        if(n==-1 && m==-1)
            break;
        maxx=-1,maxy=-1;
        memset(h,0,sizeof(h));
        memset(l,0,sizeof(l));
        while(n--){
            scanf("%d%d%d%d",&x,&y,&d,&t);
            if(d==0){
                for(int i=0;i<t;i++)
                    h[x+i][y]=inf;
                maxx=max(maxx,x+t);
                maxy=max(maxy,y);
            }else{
                for(int i=0;i<t;i++)
                    l[x][y+i]=inf;
                maxx=max(maxx,x);
                maxy=max(maxy,y+t);
            }
        }
        while(m--){
            scanf("%d%d%d",&x,&y,&d);
            if(d==0)
                h[x][y]=1;
            else
                l[x][y]=1;
        }
        scanf("%lf%lf",&f1,&f2);
        if(f1>maxx || f2>maxy){
            puts("0");
            continue;
        }
        sx=(int)f1,     sy=(int)f2;
        BFS();
        printf("%d\n",dis[sx][sy]);
    }
    return 0;
}


渣渣还需努力!


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值