Finding Nemo

/*
3:Finding Nemo
查看 提交 统计 提问
总时间限制: 2000ms 内存限制: 65536kB
描述
Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help.
After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero.
All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few doors as he could to find Nemo.
Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo.




We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.
输入
The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors. 
Then follow M lines, each containing four integers that describe a wall in the following format: 
x y d t 
(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall. 
The coordinates of two ends of any wall will be in the range of [1,199]. 
Then there are N lines that give the description of the doors: 
x y d 
x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted. 
The last line of each case contains two positive float numbers: 
f1 f2 
(f1, f2) gives the position of Nemo. And it will not lie within any wall or door. 
A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.
输出
For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.
样例输入
8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1
样例输出
5
-1
来源
Beijing 2004
*/




#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>


using namespace std;


const int N=250;
const int INF=0x3f3f3f3f;


struct node{
    int x,y;
    int door;
    bool operator < (const node &a) const{
        return a.door<door;
    }
};


int n,m,sx,sy,maxx,maxy;
int dis[N][N],h[N][N],l[N][N];


void BFS(){
    priority_queue<node> q;
    while(!q.empty())
        q.pop();
    for(int i=0;i<=maxx;i++)
        for(int j=0;j<=maxy;j++)
            dis[i][j]=INF;
    node cur;
    cur.x=0,    cur.y=0,    cur.door=0;
    dis[0][0]=0;
    q.push(cur);
    while(!q.empty()){
        cur=q.top();
        q.pop();
        int x=cur.x,    y=cur.y;
        if(x==sx && y==sy)
            return ;
        if(y+1<=maxy && dis[x][y+1]>dis[x][y]+h[x][y+1]){  //向上走
            dis[x][y+1]=dis[x][y]+h[x][y+1];
            cur.x=x;
            cur.y=y+1;
            cur.door=dis[x][y+1];
            q.push(cur);
        }
        if(y-1>=0 && dis[x][y-1]>dis[x][y]+h[x][y]){   //向下走
            dis[x][y-1]=dis[x][y]+h[x][y];
            cur.x=x;
            cur.y=y-1;
            cur.door=dis[x][y-1];
            q.push(cur);
        }
        if(x-1>=0 && dis[x-1][y]>dis[x][y]+l[x][y]){  //向左走
            dis[x-1][y]=dis[x][y]+l[x][y];
            cur.x=x-1;
            cur.y=y;
            cur.door=dis[x-1][y];
            q.push(cur);
        }
        if(x+1<=maxx && dis[x+1][y]>dis[x][y]+l[x+1][y]){     //向右走
            dis[x+1][y]=dis[x][y]+l[x+1][y];
            cur.x=x+1;
            cur.y=y;
            cur.door=dis[x+1][y];
            q.push(cur);
        }
    }
    dis[sx][sy]=-1;
}
int main(){


    //freopen("input.txt","r",stdin);


    int x,y,d,t;
    double f1,f2;
    while(~scanf("%d%d",&n,&m)){
        if(n==-1 && m==-1)
            break;
        maxx=-1,    maxy=-1;
        memset(h,0,sizeof(h));
        memset(l,0,sizeof(l));
        while(n--){
<span style="white-space:pre">			</span>cin >> x >> y >> d >> t;
            if(d==0){
                for(int i=0;i<t;i++)
                    h[x+i][y]=INF;
                maxx=max(maxx,x+t);
                maxy=max(maxy,y);
            }else{
                for(int i=0;i<t;i++)
                    l[x][y+i]=INF;
                maxx=max(maxx,x);
                maxy=max(maxy,y+t);
            }
        }
        while(m--){
            cin >> x >> y >> d;
            if(d==0)
                h[x][y]=1;
            else
                l[x][y]=1;
        }
        cin >> f1 >> f2;
        if(f1>maxx || f2>maxy){
            cout << '0';
            continue;
        }
        sx=(int)f1,sy=(int)f2;
        BFS();
        cout << dis[sx][sy] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Finding bugs(寻找错误)是指在软件开发过程中,为了保证软件的质量和稳定性,通过一系列的测试和调试过程,找出软件中存在的错误和缺陷,并进行修复的活动。 寻找错误是软件开发过程中必不可少的一步。在软件开发过程中,无论是编写代码、设计界面还是实施功能,都可能出现各种各样的错误。这些错误可能导致软件无法正常运行、功能异常或者性能低下。为了及时发现和修复这些错误,需要进行系统而全面的错误寻找工作。 寻找错误的方法和技巧有很多种。其中一种常用的方法是黑盒测试。黑盒测试是指在不了解软件内部结构和具体实现的情况下,通过输入一些指定的测试用例,观察软件的输出结果,并与预期结果进行对比,从而判断软件是否存在错误。另外一种方法是白盒测试。白盒测试是指在了解软件内部结构和具体实现的情况下,通过对代码进行逐行逐句的检查,发现其中潜在的错误。 除了以上的方法,还可以使用自动化的测试工具来辅助寻找错误。这些工具能够模拟用户的操作,快速地执行大量的测试用例,并生成详细的测试报告,帮助开发人员准确定位和修复错误。 在寻找错误的过程中,要保持耐心和专注。有时候错误可能隐藏得很深,需要仔细地分析和调试。同时,还要注重记录和总结错误,以便后续的修复工作。 总之,寻找错误是软件开发过程中不可或缺的一环。通过系统而全面的测试和调试工作,可以及时发现和修复软件中存在的错误和缺陷,提高软件的质量和可靠性。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值