Number Sequence--组合数学

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37890 Accepted: 10952

Description

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output

There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2
题目链接:http://poj.org/problem?id=1019


题目的意思很明确吧,我就不用再说了吧。

组合数学这种东西搞得我很是尴尬啊,用一个数组预处理一下位数,恩,没错,然后找到具体的数,然后,就没有然后了。。


代码

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
long long b[35001];
long long a[35001];
void fax()//预处理位数
{
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    for(int i=1;i<=35000;i++)
    {
        a[i]=a[i-1]+(int )log10((double)i)+1;
        b[i]=b[i-1]+a[i];
    }
}
int solve(int x)
{
    int i;
    for(i=0;i<=32000;i++)//找到恰好的数
    {
        if(x<=b[i+1]&&x>b[i])
            break;
    }
    x-=b[i];
    int t=0,k;
    for(i=1;;i++)
    {
        k=(int)log10((double)i)+1;
        t+=k;
        if(t>=x)
            break;
    }//计算具体的是哪一位
    if(t==x)
        return i%10;
    else
    {
        int kk=t-x;
        int h=1;
        while(kk--)
            h*=10;
        return (i/h)%10;
    }
}
int main()
{
    int x,t;
    scanf("%d",&t);
    fax();
    while(t--)
    {
        scanf("%d",&x);
        cout<<solve(x)<<endl;
    }
    return 0;
}


希望明天的比赛成绩会好吧。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值