Cash Machine--多重背包

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32817 Accepted: 11892

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

题目链接:http://poj.org/problem?id=1276


好久都没做背包的题了,背包九讲也并没有看,我还是太颓废了啊。

这个题用代码讲吧。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int dp[233333];//最接近j但小于j的值,会累计
int c[233333];//第i种物品的体积
int w[233333];//第i种物品的价值
int a[233333];//计数器
int ans[233333];//第i种物品个数
int main()
{
    int cash,n;
    int i,j;
    while(~scanf("%d%d",&cash,&n))
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&ans[i],&w[i]);
            c[i]=w[i];//此题单个物品的价值等于体积
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            memset(a,0,sizeof(a));//每一次计数器都要清零
            for(j=w[i];j<=cash;j++)//对于第i种物品,其面额w[i]~cash的各种状态都可能发生
            {
                if(dp[j]<dp[j-c[i]]+w[i]&&a[j-c[i]]<ans[i])
                {
                    dp[j]=dp[j-c[i]]+w[i];//选取第i个物品后,背包容量减少c[i];
                    a[j]=a[j-c[i]]+1;
                }
            }
        }
        printf("%d\n",dp[cash]);
    }
    return 0;
}


还是看了题解,大神的博客:

http://www.cnblogs.com/lyy289065406/archive/2011/07/31/2122631.html


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值