hdu Find a way(两路广搜)

46 篇文章 0 订阅

Find a way

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
    
    
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
    
    
66 88 66
ps:比较笨的我想的是每遇到一次@,两人就搜一次,结果果断超时了。。。。
代码:
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int maxn=202;
const int INF=0x3f3f3f3f;
char map[maxn][maxn],vis[maxn][maxn];
int dis[maxn][maxn][2];//记录下到每个@所走的步数,其中第三维代表有两个人走
int n,m,flag;
struct node
{
    int x,y,step;
};
bool judge(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m&&!vis[x][y]&&map[x][y]!='#')
        return 1;
    return 0;
}
int to[][2]= {0,1,0,-1,1,0,-1,0};
void bfs(int x,int y)
{
    node now,next;
    queue<node>q;
    now.x=x,now.y=y,now.step=0;
    q.push(now);
    vis[x][y]=1;
    while(!q.empty())
    {
        now=q.front();
        if(map[now.x][now.y]=='@')//遇到@就记录下走了多少步
            dis[now.x][now.y][flag]=now.step;
        for(int i=0; i<4; i++)
        {
            int xx=now.x+to[i][0],yy=now.y+to[i][1];
            if(judge(xx,yy))
            {
                vis[xx][yy]=1;
                next.x=xx,next.y=yy,next.step=now.step+1;
                q.push(next);
            }
        }
        q.pop();
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int i,j,s=INF;
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
                dis[i][j][0]=dis[i][j][1]=INF;//有可能有的@根本走不通,所以要初始化无穷大
        for(i=0; i<n; i++)
            scanf("%s",map[i]);
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
            {
                if(map[i][j]=='Y')
                {
                    flag=0;
                    memset(vis,0,sizeof(vis));
                    bfs(i,j);
                }
                if(map[i][j]=='M')
                {
                    flag=1;
                    memset(vis,0,sizeof(vis));
                    bfs(i,j);
                }
            }
        for(i=0; i<n; i++)
            for(j=0; j<m; j++)
            {
                if(map[i][j]=='@'&&s>dis[i][j][0]+dis[i][j][1])//找到最小步数和
                    s=dis[i][j][0]+dis[i][j][1];
            }
        printf("%d\n",s*11);
    }
    return 0;
}

ps:上述每人只需要搜一次并记录下到每一个@的步数和,最后一比较就好了。大大节省了时间。。

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值