poj Parity game(带权并查集)(hash离散化)

115 篇文章 0 订阅
21 篇文章 0 订阅
Parity game

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3


ps:和hdu 3038类似,根据d(i,j]+d(j,k]=d(i,k],就可以把所有的点通过与根节点的关系联系起来了
但是这道题最大的问题不在这里,而是它的数据太大了,所以需要离散化一下,但是,从没有用过hash离散的我到哪离散去0.0
搜了一下离散化的博客,但是要么只是告诉离散的方法,要么就是离散化的代码写了几百行0.0,就不能来个简单点的 大哭

最后还是看了本题的题解才略微明白了一点什么叫离散化

可以看到本题中的区间范围很大,但是输入的点却最多只有5000*2个,所以可以从这里入手,建立映射关系

比如建立一个f(x)的映射关系,把每一个输出的点都存入f(x)函数中,所以f(x)函数最多只有5000*2个数,而后我们查询的时候只需要借用他们映射的位置,通过其位置来实现对数据的处理,也就是说我们所用的只是这5000*2个位置与数据的关系,这样就实现了离散化(暂时我的离散化就是这样的)

代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 10000+10
struct node
{
    int u,v,w;
} a[maxn];
int pre[maxn],rank[maxn];
int f[maxn];

void init(int n)
{
    for(int i=0; i<n; i++)
    {
        pre[i]=i;
        rank[i]=0;
    }
}

int Find(int x)
{
    int temp=pre[x];
    if(x==pre[x])
        return x;
    pre[x]=Find(temp);
    rank[x]=(rank[x]+rank[temp])%2;
    return pre[x];
}

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int i,cnt=0;
        char s[10];
        for(i=1; i<=m; i++)
        {
            scanf("%d%d %s",&a[i].u,&a[i].v,s);
            a[i].u--;
            if(!strcmp(s,"even"))
                a[i].w=0;
            else
                a[i].w=1;
            f[cnt++]=a[i].u;
            f[cnt++]=a[i].v;
        }
        sort(f,f+cnt);
        n=unique(f,f+cnt)-f;
        init(n);
        int sum=0;
        for(i=1; i<=m; i++)
        {
            int x=lower_bound(f,f+n,a[i].u)-f;//查询其位置
            int y=lower_bound(f,f+n,a[i].v)-f;//
            int fx=Find(x),fy=Find(y);
            if(fx!=fy)
            {
                pre[fx]=fy;
                rank[fx]=(rank[y]+a[i].w-rank[x])%2;//通过其位置来建立关系
            }
            else
            {
                if((abs(rank[x]-rank[y])%2)!=a[i].w)
                    break;
            }
            sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值