hdu 1296 Polynomial Problem(模拟)

60 篇文章 1 订阅
22 篇文章 0 订阅

Polynomial Problem

Problem Description
We have learned how to obtain the value of a polynomial when we were a middle school student. If f(x) is a polynomial of degree n, we can let

If we have x, we can get f(x) easily. But a computer can not understand the expression like above. So we had better make a program to obtain f(x).

Input
There are multiple cases in this problem and ended by the EOF. In each case, there are two lines. One is an integer means x (0<=x<=10000), the other is an expression means f(x). All coefficients ai(0<=i<=n,1<=n<=10,-10000<=ai<=10000) are integers. A correct expression maybe likes
1003X^5+234X^4-12X^3-2X^2+987X-1000

Output
For each test case, there is only one integer means the value of f(x).

Sample Input
3
1003X^5+234X^4-12X^3-2X^2+987X-1000

Sample Output
264302

Notice that the writing habit of polynomial f(x) is usual such as
X^6+2X^5+3X^4+4X^3+5X^2+6X+7
-X^7-5X^6+3X^5-5X^4+20X^3+2X^2+3X+9
X+1
X^3+1
X^3
-X+1 etc. Any results of middle process are in the range from -1000000000 to 1000000000.

ps:直接模拟即可,注意n的取值范围

代码:

#include<stdio.h>
#include<string.h>

typedef long long int LL;
char a[1010];

LL pow(LL x,LL y)
{
    LL sum=1;
    for(LL i=1; i<=y; i++)
        sum*=x;
    return sum;
}

int main()
{
    LL x;
    while(~scanf("%lld",&x))
    {
        scanf("%s",a);
        LL len=strlen(a);
        LL ans=0,cnt,tot,flag,flog1,flog2;
        for(LL i=0; i<len; i++)
        {
            flog1=0,flog2=0;
            if(a[i]=='-')
                flag=1,i++;
            else
            {
                flag=0;
                if(a[i]=='+')
                    i++;
            }
            if(a[i]>='0'&&a[i]<='9'&&i<len)
            {
                flog1=1;
                cnt=0;
                while(a[i]>='0'&&a[i]<='9'&&i<len)
                {
                    cnt=cnt*10+(a[i]-'0');
                    i++;
                }
            }
            if(a[i]=='X'&&i<len)
            {
                flog2=1;
                if(a[i+1]=='^')
                {
                    i+=2;
                    LL t=0;
                    while(a[i]>='0'&&a[i]<='9'&&i<len)
                    {
                        t=t*10+(a[i]-'0');
                        i++;
                    }
                    i--;
                    tot=pow(x,t);
                }
                else
                    tot=x;
            }
            if(flag)
            {
                if(flog1&&flog2)
                    ans-=cnt*tot;
                else if(flog1)
                    ans-=cnt;
                else if(flog2)
                    ans-=tot;
            }
            else
            {
                if(flog1&&flog2)
                    ans+=cnt*tot;
                else if(flog1)
                    ans+=cnt;
                else if(flog2)
                    ans+=tot;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

ps:比赛时做了一个多小时就是找不出哪里错误,结果一看别人的代码,原来是没有看到n的范围,我把n当成了个一位数0.0。。
总结:做题时一定要细心,注意每一个值的取值范围,卡题一个多小时这种情况一般就是一些极限数据有些错误

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值