poj 3321 Apple Tree(树状数组)(区间建树)

115 篇文章 0 订阅
11 篇文章 0 订阅

Apple Tree

Description

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

这里写图片描述
Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.
Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1
Sample Output

3
2

ps:本题最难的就是该怎样建立一棵树,并且还要让它最后利用到树状数组的区间。
既然是区间的话,那么我们就要让这个节点和它的所有子节点都在同一个区间里,也就是区间建树了。

类似与对每一个节点进行标号,从树的根节点开始遍历,左端点记录当前节点的位置,右端点记录当前节点的最后一个子节点的位置,这样每一个节点的左右端点表示的就是[自身的位置,最后一个子节点的位置],也就相当于这个区间存储了它和它的每一个子节点

接下来我们就可以通过树状数组来修改和查询区间内的值了(具体详见代码)

注意一点,这道题卡vector,所以我用了邻接表存边。。

代码:

#include<stdio.h>
#include<string.h>

#define maxn 100010
struct node
{
    int v,next;
} G[maxn];
int a[maxn],le[maxn],ri[maxn],fork[maxn],first[maxn];
int n,m,len;

void dfs(int rt)//dfs区间建树
{
    le[rt]=len;
    for(int i=first[rt]; i!=-1; i=G[i].next)
    {
        ++len;
        dfs(G[i].v);
    }
    ri[rt]=len;
}

int lowbit(int x)
{
    return x&-x;
}

void updata(int i,int x)
{
    while(i<=n)
    {
        a[i]+=x;
        i+=lowbit(i);
    }
}

int getsum(int i)
{
    int sum=0;
    while(i)
    {
        sum+=a[i];
        i-=lowbit(i);
    }
    return sum;
}

void add_egde(int u,int v,int i)//邻接表存边
{
    G[i].v=v,G[i].next=first[u];
    first[u]=i;
}

int main()
{
    memset(first,-1,sizeof(first));
    scanf("%d",&n);
    int x,y;
    for(int i=1; i<n; ++i)
    {
        scanf("%d%d",&x,&y);
        add_egde(x,y,i);
    }
    len=1;
    dfs(1);
    for(int i=1; i<=n; ++i)
    {
        fork[i]=1;
        updata(i,1);
    }
    scanf("%d",&m);
    char s[5];
    for(int i=1; i<=m; ++i)
    {
        scanf("%s%d",s,&x);
        if(s[0]=='Q')
            printf("%d\n",getsum(ri[x])-getsum(le[x]-1));
        else
        {
            if(fork[x])//先判断是否有apple
                updata(le[x],-1);
            else
                updata(le[x],1);
            fork[x]=!fork[x];
        }
    }
    return 0;
}



总结:以前做过一道去区间建树的题目,但是做这道题时却完全没有想到要那样建树,归根结底还是对这种方法的使用场景不熟悉啊!

要多思考,多总结,才能记忆深刻!

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值