hdu 1564 Play a game(博弈——找规律)

Play a game

Problem Description

New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input

The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output

Output the winner (“8600” or “ailyanlu”) for each input line except the last zero.
No other characters should be inserted in the output.

Sample Input

2
0

Sample Output

8600

题意:有一个n*n的棋盘,棋盘的角落有一个石子,两个人轮流移动石子(8600先来),规定每次石子只能移动到当前位置的相邻位(且这个位置未被移动到过),最后谁不能移动石子则谁输,问最后谁赢

结论:当x=n*n为奇数时,后手赢,否则先手赢

证明:当x为偶数时,有y=x-1个位置可走,且y为奇数

又,若可走的步数为奇数时,先手必赢

且奇数一定可以表示为一个奇数加一个偶数的和

也就是说,以先手为主导走的路,最后一定能走到奇数步的路上,因此先手必胜

同理,若y为偶数,偶数可以表示为两个奇数的和或者两个偶数的和

只有当偶数变为奇数,也就是变为以后手为主导时,才一定可以走到奇数步的路上,因此后手必胜

详细证明博客:Boapath

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int x=n*n;
        if(x&1)
            printf("ailyanlu\n");
        else
            printf("8600\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值