hdu 4722 Good Numbers(找规律)

Good Numbers


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
   
   
2 1 10 1 20
 

Sample Output
   
   
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
 


ps:找规律中的大水题,可是我忘记了0也能整除10,以至于三个小时找了一个错误的规律~Orz

数位dp也可以做,暂时还没学0.0

代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
using namespace std;

#define LL long long int

LL solve(LL x)
{
    LL sum=x/10;
    LL first=x/10*10;
    for(LL i=first; i<=x; i++)
    {
        LL m=0,k=i;;
        while(k)
        {
            m+=(k%10);
            k/=10;
        }
        if((m%10)==0)
            return sum+1;
    }
    return sum;
}

int main()
{
    LL t,k=0;
    scanf("%lld",&t);
    while(k<t)
    {
        LL le,ri;
        scanf("%lld%lld",&le,&ri);
        le--;
        LL sum1=solve(le);
        if(le<0)
            sum1=0;
        LL sum2=solve(ri);
        LL ans=abs(sum2-sum1);
        printf("Case #%lld: ",++k);
        printf("%lld\n",ans);
    }
    return 0;
}


总结:对于极限数据的把握还不够,比赛的时候心态也不好,竟然把0能整除10给忘了,下次如果一道题错5次以上并且能确定思路正确的话,一定要多出几组数据区间的下限和上限数据,不能再犯同样的错误了 敲打
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值