Good Numbers
Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2 1 10 1 20
Sample Output
Case #1: 0 Case #2: 1HintThe answer maybe very large, we recommend you to use long long instead of int.
ps:找规律中的大水题,可是我忘记了0也能整除10,以至于三个小时找了一个错误的规律~Orz
数位dp也可以做,暂时还没学0.0
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
using namespace std;
#define LL long long int
LL solve(LL x)
{
LL sum=x/10;
LL first=x/10*10;
for(LL i=first; i<=x; i++)
{
LL m=0,k=i;;
while(k)
{
m+=(k%10);
k/=10;
}
if((m%10)==0)
return sum+1;
}
return sum;
}
int main()
{
LL t,k=0;
scanf("%lld",&t);
while(k<t)
{
LL le,ri;
scanf("%lld%lld",&le,&ri);
le--;
LL sum1=solve(le);
if(le<0)
sum1=0;
LL sum2=solve(ri);
LL ans=abs(sum2-sum1);
printf("Case #%lld: ",++k);
printf("%lld\n",ans);
}
return 0;
}
