hdu 3032 Nim or not Nim? (SG函数+打表)

Nim or not Nim?

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], …., s[N-1], representing heaps with s[0], s[1], …, s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)

Output
For each test case, output a line which contains either “Alice” or “Bob”, which is the winner of this game. Alice will play first. You may asume they never make mistakes.

Sample Input
2
3
2 2 3
2
3 3

Sample Output
Alice
Bob

思路:大数据所以肯定是找规律,但是手推数据的话很麻烦,因此我们要通过SG函数来小范围打表找规律

打表代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn=1e4+10;
int sg[maxn];

int Get_SG(int n)
{
    if(sg[n]!=-1)
        return sg[n];
    bool vis[maxn]={false};
    for(int i=0;i<n;++i)//从这一堆拿任意个
        vis[Get_SG(i)]=true;
    for(int i=1;i<=n/2;++i)//把这一堆分成两堆
        vis[Get_SG(i)^Get_SG(n-i)]=true;
    for(int i=0;;++i)
        if(!vis[i])
            return sg[n]=i;
}

int main()
{
    memset(sg,-1,sizeof(sg));
    sg[0]=0;
    Get_SG(10000);
    for(int i=0;i<=10000;++i)
        printf("sg[%d]=%d\n",i,sg[i]);
    return 0;
}



通过SG函数打表可知,
当n%4=0时,sg[n]=n-1;
当n%4=1时,sg[n]=n;
当n%4=2时,sg[n]=n;
当n%4=3时,sg[n]=n+1;

AC代码:

#include<stdio.h>

int main()
{
    int t,n,x;
    scanf("%d",&t);
    while(t--)
    {
        int ans=0;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%d",&x);
            if(x%4==3)
                ans^=(x+1);
            else if(x%4==0)
                ans^=(x-1);
            else
                ans^=x;
        }
        if(ans)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值