DFS基础题-----HDOJ1241

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2



题意大致是把一个油井分成一个矩形网格,@代表有油,*代表没有油,相连的@代表一个油区, 求有多少个油区,即有多少组相连的@

上下左右对角都算是相连


#include<cstdio>
#include<cstring>
int ju[102][102], a, b;//ju函数用来表示是否经历过遍历,遍历过的用非0表示,否则用0表示
char s[102][102];
void dfs(int i, int k, int ans){
	if(i >= a || i < 0 || k >= b || k < 0){//越界返回
		return ;
	}
	if(ju[i][k] != 0 || s[i][k] != '@'){//已遍历过的不再遍历
		return ;
	}
	ju[i][k] = ans;
	for(int m = -1; m <= 1; m++){//两个循环来遍历八个方向
		for(int n =-1; n <= 1; n++){
			if(m != 0 || n != 0){
				dfs(i + m, k + n, ans);
			}
		}
	}
}
int main(){
	while(scanf("%d%d", &a, &b) == 2){
		if(a == 0 && b == 0){
			break;
		}
		for(int i = 0; i < a; i++){
			scanf("%s", s[i]);
		}
		memset(ju, 0, sizeof(ju));//全部初始化为0
		int cnt = 0;
		for(int i = 0; i < a; i++){
			for(int k = 0; k < b; k++){
				if(ju[i][k] == 0 && s[i][k] == '@'){//没有遍历过且为@开始深搜(DFS)
					dfs(i, k, ++cnt);
				}
			}
		}
		printf("%d\n", cnt);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值