POJ-----2718---Smallest Difference---暴力

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10607 Accepted: 2896

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28
给出一串数字,把数字分拆组合成两个整数,问所有组合的差的绝对值的最小值

可以贪心来模拟

n个数升序排列,肯定平均分配

偶数直接中间分

奇数前多后少才能保证差最小

因为是升序,所以以中间两数为头,组建新的数,头大的尾就小,反之亦然

暴力代码比较简单,就没贪心,主要用到STL函数next_permutation

就是求下一个全排列,原理是对升序排列的数字,从后往前找第一个比他小的,交换,即生成下一个全排列,同理,还有一个prev_permutation,求上一个全排列,原理正好相反

手写的递归暴力全排列时间爆掉了- -

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<queue>
#include<iostream>
#define PI acos(-1.0)
#define inf 0x3f3f3f3f
using namespace std; 
const int maxn = 1e5+10;
typedef long long LL;
using namespace std;
int s[15], cnt;
int main(){
	int t;
	cin >> t;
	while(t--){
		int n = 0;
		char ch;
		while(scanf("%d%c", &s[n++], &ch) == 2 && ch != '\n');
		cnt = inf;
		if(n == 2){//避免出现0 1这种情况,在下面计算会出错
			cout << s[1]-s[0] << endl;
			continue;
		}
		while(s[0] == 0) next_permutation(s, s+n);
		do{
			int mid;
			mid = (n+1)/2;
			if(!s[mid]) continue;
			int x, y;
			x = y = 0;
			for(int i = 0; i < mid; i++) x = x*10+s[i];
			for(int i = mid; i < n; i++) y = y*10+s[i];
			int ans = abs(x-y);
			cnt = min(ans, cnt);
		}while(next_permutation(s, s+n));
		cout << cnt << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值