山东省第五届ACM省赛题——Full Binary Tree(二叉树应用)

题目描述

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.
 
You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.
 

输入

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.
 

输出

For each query, print the required answer in one line.
 

示例输入

5
1 2
2 3
4 3
1024 2048
3214567 9998877

示例输出

1
2
3
1
44

根据满二叉树的性质,节点除以二一定是它的父节点。所以可以先以其中一个点遍历至树根,同时记录需要的步数,另一个再向上遍历,遇到父节点就对比,如果相同则两个点的步数相加

#include <stdio.h>
#include<iostream>
#define MAXN 10000000
using namespace std;
struct step
{
    int node,cnt;
};
step s[MAXN];
int main()
{
     int n,right,left,i,j,ct;
     scanf("%d",&n);
     while(n--)
     {
         i=0;
         j=0;
         scanf("%d%d",&right,&left);
             s[0].node=right;
             s[0].cnt=0;
        i++;
         while(right!=1)
         {
             right/=2;
             s[i].node=right;
             s[i].cnt=i;
             i++;
         }
         ct=0;
         while(1)
         {
             if(left>s[j].node)
             {
                 left/=2;
                 ct++;
             }
             if(left==s[j].node)
             {
                 ct+=s[j].cnt;
                 break;
             }
             if(left<s[j].node)
                j++;
         }
         cout<<ct<<endl;
     }
     return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值