poj1080——Human Gene Functions(LCS变形)

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT–TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT–TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

这里写图片描述
denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
Output

The output should print the similarity of each test case, one per line.
Sample Input

2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA
Sample Output

14
21

最长公共子序列的变形。这里要求的是最大匹配数,两个序列完全不一样也可以得出一个结果。所以情况分三种
1、0——i==0或j==0时
2、dp[i-1][j-1]+match[a[i]][b[j]]
3、dp[i-1][j]+match[a[i]][’ ‘]或dp[i][j-1]+match[’ ‘][b[j]],dp[i-1][j]+match[a[i]][’ ‘]表示将a[i-1]与b[j]匹配,那么a[i]只能与空格匹配

以上除了第一种情况,其余的都有可能发生,这时就要算出这三种情况的最大值,即max(dp[i-1][j-1]+match[a[i]][b[j]],dp[i-1][j]+match[a[i]][’ ‘],dp[i][j-1]+match[’ ‘][b[j]])

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
#include <bitset>
#define MAXN 110
using namespace std;
int dp[MAXN][MAXN],match[MAXN][MAXN];
void Init()
{
    match['A']['A']=match['C']['C']=match['G']['G']=match['T']['T']=5;
    match['A']['C']=match['C']['A']=match['A']['T']=match['T']['A']=-1;
    match[' ']['T']=match['T'][' ']=-1;
    match['A']['G']=match['G']['A']=match['C']['T']=match['T']['C']=-2;
    match['G']['T']=match['T']['G']=match['G'][' ']=match[' ']['G']=-2;
    match['A'][' ']=match[' ']['A']=match['C']['G']=match['G']['C']=-3;
    match['C'][' ']=match[' ']['C']=-4;
}
char a[MAXN],b[MAXN];
int main()
{
    Init();
    int t,len1,len2,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %s",&len1,a+1);
        scanf("%d %s",&len2,b+1);
        dp[0][0]=0;
        for(i=1; i<=len1; ++i)
            dp[i][0]=dp[i-1][0]+match[a[i]][' '];
        for(i=1; i<=len2; ++i)
            dp[0][i]=dp[0][i-1]+match[' '][b[i]];
        for(i=1; i<=len1; ++i)
            for(j=1; j<=len2; ++j)
            {
                dp[i][j]=max(dp[i-1][j]+match[a[i]][' '],dp[i][j-1]+match[' '][b[j]]);
                dp[i][j]=max(dp[i][j],dp[i-1][j-1]+match[a[i]][b[j]]);
            }
        printf("%d\n",dp[len1][len2]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值