山东省第六届ACM省赛题——Circle of Friends(强连通分量+dfs)

题目描述
Nowadays, “Circle of Friends” is a very popular social networking platform in WeChat. We can share our life to friends through it or get other’s situation.
Similarly, in real life, there is also a circle of friends, friends would often get together communicating and playing to maintain friendship. And when you have difficulties, friends will generally come to help and ask nothing for return.
However, the friendship above is true friend relationship while sometimes you may regard someone as your friend but he doesn’t agree.In this way when you ask him for help, he often asks you for a meal, and then he will help you.
If two people think they are friends mutually,they will become true friend,then once one of them has a problem or makes a query, the other one will offer help for free.What’s more,if one relationship is similar to “A regards B as friend, B regards C as friend and C regards A as friend”,they will make a friends circle and become true friends too with each other. Besides, people will not ask those who they don’t regard as friends for help. If one person received a question and he can not solve it, he will ask his friends for help.
Now, Nias encounters a big problem, and he wants to look for Selina’s help. Given the network of friends, please return the minimum number of meals Nias must offer. Of course Nias is lavish enough, so he will pay for all the meals in the network of friends.

输入
The first line of input contains an integer T, indicating the number of test cases (T<=30).
For each test case, the first line contains two integers, N and M represent the number of friends in the Nias’s network and the number of relationships in that network. N and M are less than 100000 and you can assume that 0 is Nias and n-1 is Selina.
Next M lines each contains two integers A and B, represent a relationship that A regards B as his friend, A and B are between 0 and n-1.

输出
For each test case, please output the minimum number of meals Nias need to offer; if Nias can’t get Selina’s help, please output -1.
示例输入
3
4 4
0 1
1 2
2 1
2 3

3 3
0 1
1 2
2 1

3 1
0 1
示例输出
2
1
-1

题意就是缩点+建图找最短路,坑点嘛。。很多

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <set>
#include <vector>
#include <iomanip>
#include <stack>
//#include <map>
#include <queue>
#define MAXN 100010
#define mod 9973
#define INF 0x3f3f3f3f
using namespace std;
vector<int> g[MAXN];
struct Node
{
    int x,y,next;
} edge[MAXN*100];
int dfn[MAXN],low[MAXN],vis[MAXN],s[MAXN],belong[MAXN],head[MAXN];
int n,tot=0,ssum=0,ans=0,times=0,t=0,ans2;
void init()
{
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(vis,0,sizeof(vis));
    memset(low,0,sizeof(low));
    memset(belong,0,sizeof(belong));
    tot=0,ssum=0,ans=0,times=0,t=0;
}
void add(int x,int y)
{
    edge[tot].x=x;
    edge[tot].y=y;
    edge[tot].next=head[x];
    head[x]=tot++;
}
void tarjan(int x)
{
    int y,i;
    times++;
    t++;
    dfn[x]=low[x]=times;
    vis[x]=1;
    s[t]=x;
    for (i=head[x]; i!=-1; i=edge[i].next)
    {
        y=edge[i].y;
        if (vis[y]==0)
        {
            tarjan(y);
            low[x]=min(low[x],low[y]);
        }
        if (vis[y]==1)
            low[x]=min(low[x],dfn[y]);
    }
    if (dfn[x]==low[x])
    {
        ssum++;
        do
        {
            y=s[t--];
            belong[y]=ssum;
            vis[y]=2;
        }
        while (y!=x);
    }
}
bool flag;
int aans;
void dfs(int x,int st)
{
    if(x==belong[n-1])
    {
        flag=true;
        aans=aans<st?aans:st;
    }
    for(int i=0; i<g[x].size(); ++i)
    {
        int y=g[x][i];
        dfs(y,st+1);
    }
}
int main()
{
    ios::sync_with_stdio(false);
    int t,m,i,j,u,v;
    cin>>t;
    while(t--)
    {
        init();
        cin>>n>>m;
        for( i=0; i<m; i++)
        {
            cin>>u>>v;
            add(u,v);
        }
        for(i=0; i<n; ++i)
            if(!vis[i])
                tarjan(i);
        int x,y;
        for(i=0; i<=MAXN; ++i)
            g[i].clear();
        for( i=0; i<n; i++)
            for (j=head[i]; j!=-1; j=edge[j].next)
                if(belong[edge[j].x]!=belong[edge[j].y])
                {
                    x=belong[edge[j].x],y=belong[edge[j].y];
                    //cout<<"x="<<x<<" "<<"y="<<y<<endl;
                    g[x].push_back(y);
                }

        flag=false;
        aans=INF;
        dfs(belong[0],0);
        if(flag)
            cout<<aans<<endl;
        else
            cout<<"-1"<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值