Lightoj1336——Sigma Function(因子和)

Description
Sigma function is an interesting function in Number Theory. It is denoted by the Greek letter Sigma (σ). This function actually denotes the sum of all divisors of a number. For example σ(24) = 1+2+3+4+6+8+12+24=60. Sigma of small numbers is easy to find but for large numbers it is very difficult to find in a straight forward way. But mathematicians have discovered a formula to find sigma. If the prime power decomposition of an integer is

这里写图片描述

Then we can write,
这里写图片描述

For some n the value of σ(n) is odd and for others it is even. Given a value n, you will have to find how many integers from 1 to n have even value of σ.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1012).

Output
For each case, print the case number and the result.

Sample Input
4
3
10
100
1000
Sample Output
Case 1: 1
Case 2: 5
Case 3: 83
Case 4: 947

嘛,我是找不到这规律,真是咸鱼。。。
以下是别人的解题思路
解题思路:
开始就根据公式,发现只要乘积中出现一个偶数即可。然后各种打表算啊。。。
结果发现N=10000的时候程序出结果都很慢。。。这样交上去肯定TLE。
然后打表,打出100之内所有符合条件的数,然后找规律。。。。
发现只要是2^x,x^2,2*x^2…只有这种数没有出现过。所以,我们直接去重即可。
但是这些直接去重我们会发现减去的这些值有重复的,所以我们要判断下。
①2^x和x^2, 当x为偶数时二者出现重复。
②2^x和2*x^2,当x为奇数时,二者出现重复。
所以直接用N值减去x^2和2*x^2的值就是我们要的结果。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1000005
#define mod 1000000007
using namespace std;
int main()
{
    int t,cnt=1;
    long long a;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&a);
        long long num1=sqrt(a);
        long long num2=sqrt(a/2);
        printf("Case %d: %lld\n",cnt++,a-num1-num2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值