poj2828——Buy Tickets(线段树+倒插法)

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.
There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492
Sample Output

77 33 69 51
31492 20523 3890 19243
Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

这里写图片描述

看了网上的代码才知道要用倒插法。
如果两个人都想站到某个点的后面,那么最后的那个人就会站在想要的位置上,所以最先出现想插的位置上的人通过倒插法能最先确定下来,那么还想插入这个位置的其他人呢?如果左儿子的空位还大于需要插入的位置数,就往左儿子插,否则插入右儿子。
不过我搞不懂的是输出为什么不会PE?

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 200005
#define Mod 10001
using namespace std;
int pos[MAXN],val[MAXN];
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn=222222;
long long sum[maxn<<2],ans[maxn<<2];
void PushUp(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(r==l)
    {
        sum[rt]=1;
        return;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    PushUp(rt);
}
void update(int pos,int val,int l,int r,int rt)
{
    if(l==r)
    {
        ans[rt]=val;
        sum[rt]--;
        return;
    }
    int m=(l+r)>>1;
    if(sum[rt<<1]>=pos)
        update(pos,val,lson);
    else
        update(pos-sum[rt<<1],val,rson);
    PushUp(rt);
}
void show(int l,int r,int rt)
{
    if(l==r)
    {
        printf("%I64d ",ans[rt]);
        return;
    }
    int m=(l+r)>>1;
    show(lson);
    show(rson);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0; i<n; ++i)
        {
            scanf("%d%d",&pos[i],&val[i]);
        }
        build(1,n,1);
        for(int i=n-1; i>=0; --i)
            update(pos[i]+1,val[i],1,n,1);
        show(1,n,1);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值