hdu1054——Strategic Game(最小顶点覆盖+邻接表)

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

这里写图片描述

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output
1
2

用最少的点来防卫周围的点,转换成二分图就是最小顶点覆盖的问题,当然前提是懂得这个转换。。。
另外数据有点大,不能用邻接矩阵,然而poj上用邻接表的还过不了。。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
//#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1505
#define Mod 10001
using namespace std;
bool vis[MAXN];
int pre[MAXN],n;  //匹配路径;
vector<int> map[MAXN];
int find(int cur)
{
    for(int i=0; i<map[cur].size(); ++i)
    {
        int v=map[cur][i];
        if(!vis[v])
        {
            vis[v] = true;
            if(pre[v] == 0 || find(pre[v]))
            {
                pre[v] = cur;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(map,0,sizeof(map));
        int u,v,m;
        for(int i=0;i<n;++i)
        {
            scanf("%d:(%d)",&u,&m);
            while(m--)
            {
                scanf("%d",&v);
                map[v].push_back(u);
                map[u].push_back(v);
            }
        }
        int ans=0;
        memset(pre,0,sizeof(pre));
        for(int i=0;i<n;++i)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                ans++;
        }
        printf("%d\n",ans/2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值