Problem Description
Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are items of the i-th type. Further more, each item of the i-th type requires million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure.
Input
The first line of input contains an integer T which is the number of test cases. For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers and as described above. All numbers are positive integers and less than 101.
Output
For each case, output one integer, the total expenditure in million dollars.
Sample Input
1
2
1 2
3 4
Sample Output
14
#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100010
#define Mod 10001
using namespace std;
int main()
{
int t,n;
scanf("%d",&t);
long long sum,a,b;
while(t--)
{
sum=0;
scanf("%d",&n);
while(n--)
{
scanf("%I64d%I64d",&a,&b);
sum+=(a*b);
}
printf("%I64d\n",sum);
}
return 0;
}