poj2506——Tiling(递推+大数加)

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles?
Here is a sample tiling of a 2x17 rectangle.
这里写图片描述

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.
Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle.
Sample Input

2
8
12
100
200
Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

给2x1和2x2的地板,求铺成2xn的面积有多少种排列方式
网上找的,都是大神,真的。说什么a[n]=a[n-1]+2*a[n-2],反正我是没看出来

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;
string a[300];
string Add(string s1,string s2)
{
    if (s1.length()<s2.length())
        swap(s1,s2);
    int i,j;
    for(i=s1.length()-1,j=s2.length()-1;i>=0;i--,j--)
    {
        s1[i]=s1[i]+(j>=0?s2[j]-'0':0);
        if(s1[i]-'0'>=10)
        {
            s1[i]=(s1[i]-'0')%10+'0';
            if(i) s1[i-1]++;
            else s1='1'+s1;
        }
    }
    return s1;
}
int main()
{
    int i,n;
    a[0]="1",a[1]="1",a[2]="3";
    for (i=3; i<=250; i++)
        a[i]=Add(Add(a[i-1],a[i-2]),a[i-2]);
    while (cin>>n)
       cout<<a[n]<<endl;
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值