poj1035——Spell checker

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.
Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character ‘#’ on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character ‘#’ on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.
Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: ” is correct”. If the word is not correct then write this word first, then write the character ‘:’ (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.
Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#
Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

给了一些正确的单词,然后再给一些词语判断是否正确,错误的话可能转换成那些单词,转换的方法有替换一个字母,增加或删除一个字母。
没别的方法,就模拟。话说调试的时候cb又不能打开控制台窗口,本来想用老办法在任务管理器里结束进程,结果这次还不能结束,重启太麻烦,还是硬着头皮用ideone调好。。。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 105
#define Mod 10001
using namespace std;
int main()
{
    string dic[10005],word[10005],q[10005];
    int d=0,w=0;
    while(cin>>dic[d])
    {
        if(dic[d][0]=='#')
            break;
        d++;
    }
    while(cin>>word[w])
    {
        if(word[w][0]=='#')
            break;
        w++;
    }
    int ans,top,flag;
    for(int i=0; i<w; ++i)
    {
        top=0;
        int flag1=0;
        for(int j=0; j<d; ++j)
        {
            if(word[i]==dic[j])
            {
                cout<<word[i]<<" is correct"<<endl;
                flag1=1;
                break;
            }
        }
        if(!flag1)
        {
            flag=0;
            for(int j=0; j<d; ++j)
            {
                ans=0;
                if(word[i].size()==dic[j].size())
                {
                    for(int x=0,y=0; x<word[i].size(); ++x,++y)
                    {
                        if(word[i][x]==dic[j][y])
                            ans++;
                    }
                    if(ans==word[i].size()-1)
                    {
                        q[top++]=dic[j];
                        flag=1;
                    }
                }
                else if(word[i].size()==dic[j].size()-1)
                {
                    for(int x=0,y=0; y<dic[j].size(); ++y)
                    {
                        if(word[i][x]==dic[j][y])
                        {
                            ans++;
                            x++;
                        }
                    }
                    if(ans==word[i].size())
                    {
                        q[top++]=dic[j];
                        flag=1;
                    }
                }
                else if(word[i].size()==dic[j].size()+1)
                {
                    for(int x=0,y=0; x<word[i].size(); ++x)
                    {
                        if(word[i][x]==dic[j][y])
                        {
                            ans++;
                            y++;
                        }
                    }
                    if(ans==dic[j].size())
                    {
                        q[top++]=dic[j];
                        flag=1;
                    }
                }


            }
            cout<<word[i]<<": ";
            if(flag)
            {
                cout<<q[0];
                for(int t=1; t<top; ++t)
                    cout<<" "<<q[t];
            }
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值