poj3122——Pie(二分+贪心)

Description

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input

One line with a positive integer: the number of test cases. Then for each test case:
One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.
Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.
Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output

25.1327
3.1416
50.2655

一开始题意看不太懂,后来才知道是给了n个pai派和f+1个人,每个人分到的派体积必须一样,并且一个人只能吃一种派,所以可能会有派没有分完,求每个人最多分到多少派。
用二分可以高效率地解决这道题,每个人最低肯定是0,最高是全部,在这个区间内二分搜索,每次二分到一个mid值就算出每个派能给多少人,将总人数与f比较,大于f就说明mid小了,还可以再增加。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 500005
#define Mod 10001
using namespace std;
double pile[10005];
double pi=3.14159265358979323846;
int main()
{
    int t,n,f;
    scanf("%d",&t);
    while(t--)
    {
        double r,sum=0;
        scanf("%d%d",&n,&f);
        f++;
        for(int i=1;i<=n;++i)
        {
            scanf("%lf",&r);
            pile[i]=r*r*pi;
            sum+=pile[i];
        }
        double low=0,high=sum,mid;
        while(high-low>0.0000001)
        {
            int cnt=0;
            mid=(high+low)/2;
            for(int i=1;i<=n;++i)
                cnt+=(int)(pile[i]/mid);
            if(cnt>=f)
                low=mid;
            else
                high=mid;
        }
        printf("%.4lf\n",mid);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值