poj3349——Snowflake Snow Snowflakes(hash表)

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output

Twin snowflakes found.

给出n个六瓣雪花的每个瓣的长度,求是否有完全相同的雪花。
因为给出的数据很大并且很多,要用哈希表将瓣总长相等的雪花放在一个键里,以后只要算出雪花的总瓣长,再在这个长度的雪花里找是否有相同的。
另外,题目是说相等的条件是“相应的瓣长相等”,貌似是顺序也应该相等,但我没判断位置也过了。。。
第一次用哈希表,发现那个模的值可以随便取,不过可以预见这个值太小了就会有非常多总瓣长相等的雪花,效率下降,但如果太大了就会超内存。我试了一些数据得出的结论。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 10001
using namespace std;
struct Node
{
    int flakes[10];
};
Node snow[MAXN][100];
int m[MAXN];
int check(Node x,Node y)
{
    sort(x.flakes,x.flakes+6);
    sort(y.flakes,y.flakes+6);
    for(int i=0; i<6; ++i)
        if(x.flakes[i]!=y.flakes[i])
            return false;
    return true;
}
int main()
{
    int n,sum,flag;
    scanf("%d",&n);
    Node tmp;
    memset(m,0,sizeof(m));
    flag=0;
    for(int i=0; i<n; ++i)
    {
        sum=0;
        for(int j=0; j<6; ++j)
        {
            scanf("%d",&tmp.flakes[j]);
            sum=(sum+tmp.flakes[j])%10000;
        }
        if(flag==0)
        {
            for(int j=0; j<m[sum]; ++j)
                if(check(tmp,snow[sum][j]))
                {
                    flag=1;
                    break;
                }
            snow[sum][m[sum]]=tmp;
            m[sum]++;
        }
    }
    if(flag)
        printf("Twin snowflakes found.\n");
    else
        printf("No two snowflakes are alike.\n");
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值