poj3687——Labeling Balls(拓扑排序)

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like “The ball labeled with a is lighter than the one labeled with b”.
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls’ weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on… If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2
Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

编号为a的球轻于b的球,求可能的重量从小到大的排序请况。越在前面的球编号尽量越小。
将轻重有关系的球建图,从编号由大到小遍历,如果有没有比它更重的球,那这个球就是最重的,并从图里去除相关的关系。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <map>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 205
#define Mod 10001
using namespace std;
int n,m;
int mp[MAXN][MAXN],indegree[MAXN],ans[MAXN];
int main()
{
    int t,a,b,j,i;
    scanf("%d",&t);
    while(t--)
    {
        memset(mp,0,sizeof(mp));
        memset(indegree,0,sizeof(indegree));
        scanf("%d%d",&n,&m);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            if(!mp[b][a])
            {
                mp[b][a]=1;
                indegree[a]++;
            }
        }
        for(i=n; i>=1; --i)
        {
            for(j=n; j>=1; --j)
            {
                if(indegree[j]==0)
                {
                    indegree[j]--;
                    ans[j]=i;
                    for(int k=1; k<=n; ++k)
                        if(mp[j][k])
                            indegree[k]--;
                    break;
                }
            }
            if(j<1)
                break;
        }
        if(i>=1)
            cout<<"-1"<<endl;
        else
        {
            cout<<ans[1];
            for(int i=2; i<=n; ++i)
                cout<<" "<<ans[i];
            cout<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值