poj1942——Paths on a Grid(求阶乘)

41 篇文章 0 订阅
29 篇文章 0 订阅

Description

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he’s explaining that (a+b)2=a2+2ab+b2). So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let’s call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:
这里写图片描述

Really a masterpiece, isn’t it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?
Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.
Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.
Sample Input

5 4
1 1
0 0
Sample Output

126
2

在n*m个格子的纸上,从左下角开始,只能向上或者向右走到右上角,求总共有多少种走法。
无论怎样,总共能走n+m步,其中如果n步都是向上,那m步都是向右,例图中就是4步向上,5步向右。所以结果就是在m+n步中做组合,Cm+n,n或者Cm+n,m都行,排列的性质如此。
所以题目就是快速求阶乘,求阶乘的公式里,可以将这个公式转化成分数连乘,设阶乘Cm,n分子首先被n!约掉,所以分子从n+1开始乘,而后分母就剩下了(m-n)!,所以从1开始,跟着分子乘完就行,具体看代码

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 100005
#define Mod 10001
using namespace std;
long long fuck(long long m,long long n)
{
    long long i,j,x=1;
    for(i=n+1,j=1;i<=m;++i,++j)
        x=x*i/j;
    return x;
}
int main()
{

    long long n,m;
    while(~scanf("%I64d%I64d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        long long x=n;
        if(x<m)
            x=m;
        printf("%I64d\n",fuck(n+m,x));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值